Article View: comp.mail.headers
Article #245Re: Headers??? How many formats?
From: Bruce Lilly
Date: Thu, 21 Jan 1993 23:47
Date: Thu, 21 Jan 1993 23:47
25 lines
1638 bytes
1638 bytes
In article <1993Jan19.211424.9632@news.csuohio.edu>, posted to comp.mail.headers, damin@ullman.cba.csuohio.edu (Greg Boehnlein) wrote: > Once the mail was AT these locations, it >was my job to pick up the mail files in their original format, download >them to our gateway machines, parse and distribute them, converting in the >process between the Internet (RFC 822) standards and our FutureNet standards. mail != files. In order to deliver the messages, you don't want to look at the headers, you want to look at the envelope address. The same applies to the return address; it comes from the envelope, not the headers. It is perfectly legal to have a message with no To: header and an empty Bcc: header. If you must deal with the message as a stream of characters (or a disk file), I'd recommend using an SMTP-formatted message, where the envelope addresses are contained in the SMTP MAIL FROM (or SAML/SOML/SEND FROM) and RCPT TO commands. This is sometimes called batched SMTP. RFC821 (as amended by RFC1123) is the SMTP specification. -- Bruce Lilly ...uupsi!monymsys!sonyd1!blilly!bruce
Technical Details
Message-ID:
<1993Jan21.234753.20583@blilly.uucp>Path:
arc1-ca.pugleaf.net!sparky!uunet!spool.mu.edu!sgiblab!daver!hico2!sonyd1.broadcast.sony.com!blilly.uucp!bruceReferences:
<1jh8mbINNqlb@daisy.ee.und.ac.za> <1993Jan19.193144.3580@netcom.com> <1993Jan19.211424.9632@news.csuohio.edu>Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.headers Path: arc1-ca.pugleaf.net!sparky!uunet!spool.mu.edu!sgiblab!daver!hico2!sonyd1.broadcast.sony.com!blilly.uucp!bruce From: bruce@blilly.uucp (Bruce Lilly) Subject: Re: Headers??? How many formats? References: <1jh8mbINNqlb@daisy.ee.und.ac.za> <1993Jan19.193144.3580@netcom.com> <1993Jan19.211424.9632@news.csuohio.edu> Organization: Bruce Lilly Date: Thu, 21 Jan 93 23:47:53 GMT Message-ID: <1993Jan21.234753.20583@blilly.uucp> Reply-To: lilb@sony.compuserve.com (Bruce Lilly) Lines: 25