Thread View: comp.mail.misc
2 messages
2 total messages
Started by David Paigen
Tue, 01 Sep 1992 18:08
Canonical list of mail headers?
Author: David Paigen
Date: Tue, 01 Sep 1992 18:08
Date: Tue, 01 Sep 1992 18:08
13 lines
951 bytes
951 bytes
I have read through RFC 822, but there are many headers that I see on occasion that are not listed in that document. Is there a list of the "official" mail headers? Or, does anyone have a good list of the headers that you see more than once in a lifetime? Things like: Precedence, X-Mailer, etc. (Yes, I know the later is not 'official'). ----------------------->"Lay on, McDuff, 14th c. ideals in a 21st c. world David Paigen and damn'd be he N: PLO Bush IRA CIA KKK TRW Financial Systems who first cries, S: terrorism pipe bomb kill paigen@tfs.com 'hold, enough!'" A: assasination maim
Re: Canonical list of mail headers?
Author: Steven D. Majewski
Date: Tue, 01 Sep 1992 23:56
Date: Tue, 01 Sep 1992 23:56
118 lines
3079 bytes
3079 bytes
In article <1992Sep1.180842.4553@tfs.com> paigen@tfs.com (David Paigen) writes:
>I have read through RFC 822, but there are many headers that
>I see on occasion that are not listed in that document. Is
>there a list of the "official" mail headers? Or, does anyone
>have a good list of the headers that you see more than once in
>a lifetime?
>
>Things like: Precedence, X-Mailer, etc. (Yes, I know the later
>is not 'official').
>
Well, for a start here are the "official" ones I could find in various RFC's.
Please send your submissions to comp.mail.headers.
======== "If you have a hammer, find a nail" - George Bush,'91 =========
Steven D. Majewski University of Virginia Physiology Dept.
sdm7g@Virginia.EDU Box 449 Health Sciences Center
Voice: (804)-982-0831/32 1300 Jefferson Park Avenue
FAX: (804)-982-1616 Charlottesville, VA 22908
-----------------
RFC822: Standard for ARPA Internet Text Messages:
-Minimum Required:
Date:
From:
To: or Bcc:
-destination:
To:
Resent-To:
Cc:
Resent-cc:
Bcc:
Resent-bcc:
-optional field:
Message-ID:
Resent-Message-ID:
In-Reply-To:
References:
Keywords:
Subject:
Comments:
Encrypted:
Reply-To:
-Other ( appended ):
Resent-Reply-To:
Resent-From:
Resent-Sender:
Resent-Date:
Return-path:
Received:
RFC1036: Standard for the interchange of Usenet Messages (News):
[ "Certain Headers are required, and certains other headers are optional. Any
unrecognized headers are allowed, and will be passed through unchanged."]
-Required Headers:
From:
Date:
Newsgroups: group.1[,group.2,...]
Subject:
Message-ID: <unique@full_domain_name>
Path:
-Optional Headers:
Followup-To:
Expires:
Reply-To:
Sender:
References:
Control:
Distribution:
Keywords:
Summary:
Approved:
Lines:
Xref: (local info only, don't send)
Organization:
RFC1049: A Content-type header field for Internet Messages:
defines
Content-Type: { POSTSCRIPT | SCRIBE | SGML | TROFF | DVI | X-atom }
RFC1154: Encoding Header Field for Internet Messages:
defines
Encoding:
RFC1341: MIME:Multipurpose Internet Mail Extensions
MIME-Version:
Content-Type:
Content-Transfer-Encoding:
Content-ID:
Content-Description:
---------
Are "Status:" and "Precedence:" defined somewhere ?
What are the common ( and FUNCTIONAL, i.e. not just decorative ) X-extensions: ?
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads