Thread View: comp.mail.misc
3 messages
3 total messages
Started by Richard Shuford
Mon, 26 Apr 1993 21:57
America OnLine creates infinite mail loop
Author: Richard Shuford
Date: Mon, 26 Apr 1993 21:57
Date: Mon, 26 Apr 1993 21:57
27 lines
2325 bytes
2325 bytes
This is a lesson learned today by hard experience: Maintainers of automated electronic mailing lists should beware that the Internet e-mail gateway of the America OnLine commercial conferencing system does NOT honor the RFC822 "Errors-To:" header. In the event that a message from the Internet is undeliverable to "joeuser@AOL.COM", an error message, in which the full text of the failed inbound message is embedded, will be returned to the "From:" address. If the "From:" address is that of an automated mailing list to which joeuser@AOL.COM belongs, when the error message gets back to the mailing-list-host computer, the list host will send the ERROR message out to the members of the mailing list. Including joeuser@AOL.COM. The result is an infinite mail loop between the list-host computer and AOL.COM, with replicated copies of the increasingly large corpus of nested error messages going to every member of the mailing list. Naturally, maintainers of automated network mailing lists should be cautious when an AOL.COM user wants to join a list. -- ...Richard S. Shuford | "Do not move an ancient boundary stone ...shuford@cs.utk.edu | set up by your forefathers." ...Info-Stratus Coord. | Proverbs 22:28 NIV
Re: America OnLine creates infinite mail loop
Author: Erik Naggum
Date: Mon, 26 Apr 1993 23:11
Date: Mon, 26 Apr 1993 23:11
55 lines
3576 bytes
3576 bytes
[Richard Shuford] : | Maintainers of automated electronic mailing lists should beware that | the Internet e-mail gateway of the America OnLine commercial | conferencing system does NOT honor the RFC822 "Errors-To:" header. There is no RFC 822 Errors-To header. It is a sendmailism. sendmail and RFC 822 are very seldom in agreement, and if so only by coincidence, such as being tended by a diligent systems manager who has junked the vendor configuration files, and even the vendor's version of sendmail. | In the event that a message from the Internet is undeliverable to | "joeuser@AOL.COM", an error message, in which the full text of the | failed inbound message is embedded, will be returned to the "From:" | address. Without further evidence (it is in the mail), we cannot be sure that you have followed RFC 821 on this point, that is, set the envelope header right. You may be using one of the less clever automated mailing list software around, and then that is at fault, not AOL.COM. | If the "From:" address is that of an automated mailing list to which | joeuser@AOL.COM belongs, when the error message gets back to the | mailing-list-host computer, the list host will send the ERROR message | out to the members of the mailing list. Including joeuser@AOL.COM. Why have you set the From header to the mailing list? It held the author of the message before you started messing with it, did it not? If you start to claim that people are doing evil things to you, clean up your own place first. Mailing lists do not generate messages, they distribute them. A big difference that is lost on some of the less clever automated mailing list software around. | Naturally, maintainers of automated network mailing lists should be | cautious when an AOL.COM user wants to join a list. Until further evidence is available, the error might well be in your particular mailing list software, not in AOL's handling of errors. I suggest you calm down, read the specifications you point to, and just stay out of this business of recommending what people should do when you lack the prerequisite clue yourself. Of course, AOL.COM may be doing the wrong thing, too, but in that case, only the author of the message distributed to a mailing list would get annoyed if the mailing list distribution software did the right thing. See also RFC 1123 Internet Host Requirements, on mail. Best regards, </Erik> -- Erik Naggum ISO 8879 SGML +47 2295 0313 Oslo, Norway ISO 10744 HyTime <erik@naggum.no> ISO 9899 C Memento, terrigena <SGML@ifi.uio.no> ISO 10646 UCS Memento, vita brevis
Re: America OnLine creates infinite mail loop (repost)
Author: Richard Shuford
Date: Sun, 02 May 1993 05:14
Date: Sun, 02 May 1993 05:14
171 lines
8951 bytes
8951 bytes
In article <0frJ7c_SMUgERMYkgc@transarc.com>,
Craig_Everhart@transarc.com writes:
>
> Excerpts from netnews.comp.mail.misc: 26-Apr-93 Re: America OnLine
> creates .. Jason Haar@csc.canterbur (554)
>
> > In <1rhlt4INNirb@CS.UTK.EDU> Richard Shuford (shuford@cs.utk.edu) wrote:
> >
> > > Maintainers of automated electronic mailing lists should beware that
> > > the Internet e-mail gateway of the America OnLine commercial
> > > conferencing system does NOT honor the RFC822 "Errors-To:" header.
> >
> > Just a wee point here - Errors-To is _not_ mentioned in RFC822 - in fact,
>
> ...if you're using SMTP, you're to use the SMTP ``RCPT TO:'' [sic]
> argument as the address to which errors are to be reported.
> (I call this the ``envelope from'' address.)
>
> I don't know if AOL.COM mail errors are sent to the RCPT TO: address for
> incoming SMTP mail. In any case, the Errors-To: is in no protocol
> document other than perhaps an old Sendmail manual and an
> experimental/obsolete parenthetical remark in RFC 1035.
All right, already. I've been flamed by mail and derogated in the
newsgroup. And between the news system being down a day here and
having a life other than running mailing lists, I have not gotten
back to you about this thing. I do thank Hunter Goatley for making
some effort to clarify what was going on.
I made a little mistake. But AOL first made a bigger mistake.
In my fatigue and haste on Monday afternoon, in my posting I mixed up
the description of which header lines should be used for mail errors
and which header line America OnLine is in fact using for mail errors.
And I posted something Friday that is now cancelled (except for the
BITNET folks...) in which I made the further mistake of thoughtlessly
copying verbatim something somebody sent to me. But a better authority
has sent me some e-mail, from which I'll quote below.
-------------------------------
There are several ways a mail agent might plausibly respond to an error
condition. I mentioned several of these in the now-cancelled posting.
But where the Simple Mail Transfer Protocol is involved, John Klensin
<klensin@infoods.mit.edu> was kind enough to inform that errors about
mail messages being undeliverable should be sent to:
| ... the [SMTP] "envelope from" address ... "MAIL FROM"
|
| If the delivering SMTP server is correct/conforming, it places this
| address into the RFC822 header as "Return-path" just before dropping
| the mail in the local mailbox or handing it off to the Mail User Agent.
|
| For an SMTP server, that is where you stop. No other places, no
| fallbacks to any RFC822 fields. This isn't just protocol convention:
| there is an important technical loop-preventing issue.
|
| The RFC822 [header] comes into play if, and only if, transport and the
| delivery attempt that stimulated the bounce did not occur over SMTP.
| Even then, if SMTP was involved at some point in the transaction, and
| you have a legitimate Return-path field, that is where the bounce ought
| to go.
What America OnLine actually does use is neither the envelope "MAIL From"
information nor any of the plausible addresses from the RFC822 header.
America OnLine, at least as of Monday, uses
the RFC822 "Reply-To:" address
Here follows the first of the many error messages AOL bounced back.
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
| Received: from hp81.prod.aol.net by MIKE.LRC.EDU (MX V3.2) with SMTP;
| Sun, 25 Apr 1993 14:11:19 EDT
| Received: from sco1.prod.aol.net by hp81.prod.aol.net with SMTP
| (1.37.109.4/16.2) id AA15733; Sun, 25 Apr 93 14:14:37 -0400
| From: Postmaster@aol.com
| X-Mailer: America Online Mailer
| To: Info-Stratus@mike.lrc.edu
| Subject: Returned Mail Unknown Member
| Date: Sun, 25 Apr 93 14:10:18 EDT
| Message-Id: <9304251410.tn89536@aol.com>
|
| The mail you sent could not be delivered; it was addressed to an unknown
| user. The text you sent follows...
|
| I recently heard that version of FTX below 2.0 will support s$ calls for
| moving from VOS to UNIX. If this is true, then could someone mention
| the downside such as performance and possible conflicts.
|
|
| ----------------------- Headers ------------------------
| >From uupsi7!mike.lrc.edu!owner-info-stratus Sun Apr 25 14:10:06 1993 remote
| from aolsys
| Received: from uupsi7 by aolsys.aol.com id aa05034; Sun, 25 Apr 93 14:06:45
| EDT
| Received: from mike.lrc.edu by uu7.psi.com (5.65b/4.0.071791-PSI/PSINet)
| via SMTP;
| id AA01400 for jonschmidt; Sun, 25 Apr 93 13:58:53 -0400
| X-Listname: "Gatewayed with comp.sys.stratus." <Info-Stratus@mike.lrc.edu>
| Warnings-To: <>
| Errors-To: owner-info-stratus@mike.lrc.edu
| Sender: owner-info-stratus@mike.lrc.edu
| Received: by mike.lrc.edu (MX V3.2) with SITE; Sun, 25 Apr 1993 13:46:53 EDT
| To: <info-stratus@mike.lrc.edu>
| Subject: ftx support s$ calls
| Message-Id: <1993Apr23.112341.20569@porthos.cc.bellcore.com>
| From: dante@decoy.cc.bellcore.com (dante,joseph e)
| Reply-To: Info-Stratus@mike.lrc.edu
| Date: Fri, 23 Apr 93 11:23:41 GMT
| Organization: Bellcore, Livingston, NJ
|
\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
During SMTP transmission, the MX software presented this envelope line
MAIL From <owner-info-stratus@mike.lrc.edu>
which is typically copied into the "Return-Path:" header.
As you can see from the preserved headers, the address
<Info-Stratus@mike.lrc.edu>
appears ONLY in the "To:" and the "Reply-To:" headers. America OnLine's
gateway had to work pretty hard to find this address.
But the AOL gateway did find the address, so it did dispatch the error
message to the entire mailing list, and then the gateway worked
equally hard each time the list host distributed the message to the
entire mailing list, including the sad, nonfunctional "joeuser@AOL.COM".
(Names have been changed to protect the presumed innocent.)
Upon receiving each message distributed to the list, AOL.COM immediately
generated a new error message in which THE ENTIRE PREVIOUS error message
was embedded, and sent it back to Info-Stratus@mike.lrc.edu. This was an
infinite loop of missives of ever increasing size.
The fact that "joeuser@AOL.COM" was near the tail end of the mailing
list slowed the frequency of bouncing. (I'm sure glad the mailing list
is not alphabetized by hostname!) Otherwise the incident would have
gotten even worse than it was before I could stop it.
John Klensin's further commentary:
| The rule is that, when a nondelivery message is sent out by mail, the
| MAIL FROM address (you remember, the envelope) on that message--the
| one AOL sends back to you (the list in this case)--is required to be
| written as:
|
| MAIL FROM: <>
|
| That is a null address. It documents the important principle that
| sending error messages in response to error messages usually produces
| bad effects. And the reason for not looking past MAIL FROM in figuring
| out where to send error replies is precisely that--a null address in
| the envelope from address tells you to just forget it, not to look further.
I thought that the community of people who use network e-mail would like
to be warned about this.
Last Monday I caused a complaint regarding this behavior to be dispatched
to "postmaster@AOL.COM", but I have detected no reply as of yet.
--
...Richard S. Shuford | "A prudent man sees danger and takes refuge,
...shuford@cs.utk.edu | but the simple keep going and suffer for it."
...Info-Stratus Coord. | Proverbs 22:3 NIV
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads