Article View: comp.os.linux.networking
Article #736Re: LINUX-DHCP-ADSL-Connection
From: Antoine EMERIT
Date: Mon, 07 Oct 2002 07:45
Date: Mon, 07 Oct 2002 07:45
76 lines
5269 bytes
5269 bytes
Cyril Raphanel wrote: > Hi, > > I am trying to get my adsl (ethernet-modem) connection working under > linux. > > It work fine under Windows 2000 just by setting a DHCP connection. > > I have been trying dhcpcd - pump and drakconnect but i cannot get it > work. > > Here you can find couple of things i have tried. > > Please help me to avoid the use of win2000 for network purpose ;-) > > -- My config > Ethernet card : 3Com Etherlink III ISA 3C509b > Modem adsl where my network card is plugged : Nokia MP5121 > Linux distribution : Mandrake 9 > Kernel : 2.4.19 > ADSL provider : Elisa Finland > Protocol support by modem and provider : RFC1483 > Protocol support by dhcpcd : RFC2131 - RFC1541 > Protocol support by pump : ????? > > -- My Command : dhcpcd -d eth0 > > -- while running ifconfig gives > eth0 Lien encap:Ethernet HWaddr 00:60:97:DD:5E:53 > UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1 > RX packets:0 errors:0 dropped:0 overruns:0 frame:0 > TX packets:32 errors:0 dropped:0 overruns:0 carrier:0 > collisions:0 lg file transmission:100 > RX bytes:0 (0.0 b) TX bytes:18880 (18.4 Kb) > Interruption:12 Adresse de base:0x220 > > lo Lien encap:Boucle locale > inet adr:127.0.0.1 Masque:255.0.0.0 > UP LOOPBACK RUNNING MTU:16436 Metric:1 > RX packets:38 errors:0 dropped:0 overruns:0 frame:0 > TX packets:38 errors:0 dropped:0 overruns:0 carrier:0 > collisions:0 lg file transmission:0 > RX bytes:4672 (4.5 Kb) TX bytes:4672 (4.5 Kb) > > -- end of dhcpcd > dhcpcd: MAC address = 00:60:97:dd:5e:53 > > -- now ifconfig gives > lo Lien encap:Boucle locale > inet adr:127.0.0.1 Masque:255.0.0.0 > UP LOOPBACK RUNNING MTU:16436 Metric:1 > RX packets:38 errors:0 dropped:0 overruns:0 frame:0 > TX packets:38 errors:0 dropped:0 overruns:0 carrier:0 > collisions:0 lg file transmission:0 > RX bytes:4672 (4.5 Kb) TX bytes:4672 (4.5 Kb) > > -- I try with pump > I got the same ifconfig results > Error message : Operation failed I don't think that DHCP is involved in your ADSL trouble. DHCP is used on LAN with a local dhcp server, or in cable modem served by internet cable service (UPS, ...). With ADSL modem, the IP are returned by the ADSL protocol : PPTP or PPOE or PPOA. You should run some pp* daemon to connect to the adsl modem (pptp, pppoe, ...) that launch pppd to open the ip tunnel to your ADSL provider. When your ADSL connection us up you should see a ppp0 (or ppp1, ...) interface listed with 'ipconfig'. Note: Windows say "dinamic ip address" for many differents protocols.
Technical Details
Message-ID:
<3DA139BB.2080101@online.fr>Path:
arc1-ca.pugleaf.net!archiver1.google.com!news1.google.com!newsfeed.stanford.edu!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!newsfeed.icl.net!newsfeed.fjserv.net!newsfeed.icl.net!newsfeed.fjserv.net!oleane.net!oleane!News.neptune.fr!not-for-mailReferences:
<Xns929E9EEB26FEFcyrilraphanelnetcour@193.229.0.31>Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: 10669a,61c8a3b24c43394b
X-Google-Attributes: gid10669a,public
X-Google-Thread: f8ece,61c8a3b24c43394b
X-Google-Attributes: gidf8ece,public
X-Google-ArrivalTime: 2002-10-07 01:01:05 PST
X-Original-Received: from trinity.supernews.net
(trinity.delta.supernews.net [216.168.2.22]) by Titan.neptune.fr
(8.11.6/8.11.6) with ESMTP id g977bf211385 for <fcolc@neptune.fr>;
Mon, 7 Oct 2002 09:37:42 +0200
X-Original-Received: from smarthost0.mail.uk.easynet.net ([212.135.6.10])
by trinity.supernews.net with esmtp (Exim 3.36 #1) id 17ySSQ-0002RR-00 for
fr-comp-os-linux-configuration@moderators.isc.org; Mon, 07 Oct 2002
07:37:39 +0000
X-Original-Received: from [212.135.5.71] (helo=brahe.news.easynet.net) by
smarthost0.mail.uk.easynet.net with esmtp (Exim 3.35 #1) id
17ySSO-0007oI-00 for fr-comp-os-linux-configuration@moderators.isc.org;
Mon, 07 Oct 2002 08:37:37 +0100
X-Original-Received: from news by brahe.news.easynet.net with local (Exim
3.36 #2) id 17ySSJ-0000Du-00 for
fr-comp-os-linux-configuration@moderators.isc.org; Mon, 07 Oct 2002
08:37:31 +0100
Message-ID: <3DA139BB.2080101@online.fr>
From: Antoine EMERIT <antoine.emerit@online.fr>
X-Accept-Language: fr-fr, en-us, en
MIME-Version: 1.0
Newsgroups: comp.os.linux.networking,fr.comp.os.linux.configuration
Subject: Re: LINUX-DHCP-ADSL-Connection
References: <Xns929E9EEB26FEFcyrilraphanelnetcour@193.229.0.31>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Organization: [posted via Easynet France]
X-Trace: DXC=`8CcJDE`bee:O3>7Se`S@`20^i3:fnNMmXk]QKW=WO9l
X-MailScanner: Found to be clean
X-Modappbot-Status: autoposted
X-Original-Sender: <news@brahe.news.easynet.net>
X-Original-Return-Path: <mail@Titan.neptune.fr>
X-Original-User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1)
Gecko/20020826
X-Original-NNTP-Posting-Host: 212.11.5.news.easynet.fr
X-Original-Date: Mon, 07 Oct 2002 09:37:31 +0200
Path: arc1-ca.pugleaf.net!archiver1.google.com!news1.google.com!newsfeed.stanford.edu!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!newsfeed.icl.net!newsfeed.fjserv.net!newsfeed.icl.net!newsfeed.fjserv.net!oleane.net!oleane!News.neptune.fr!not-for-mail
Sender: fcolc-admin@neptune.fr
Approved: fcolc@neptune.fr
X-Modappbot-Version: 0.4.4
Date: 07 Oct 2002 07:45:02 GMT
Lines: 76