🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.os.linux.networking
Article #737

LINUX-DHCP-ADSL-Connection

#737
From: Cyril Raphanel
Date: Sat, 05 Oct 2002 12:45
58 lines
4298 bytes
Hi,

I am trying to get my adsl (ethernet-modem) connection working under 
linux.

It work fine under Windows 2000 just by setting a DHCP connection.

I have been trying dhcpcd - pump and drakconnect but i cannot get it 
work.

Here you can find couple of things i have tried.

Please help me to avoid the use of win2000 for network purpose ;-)

-- My config
Ethernet card : 3Com Etherlink III ISA 3C509b
Modem adsl where my network card is plugged : Nokia MP5121
Linux distribution : Mandrake 9
Kernel : 2.4.19
ADSL provider : Elisa Finland
Protocol support by modem and provider : RFC1483
Protocol support by dhcpcd : RFC2131 - RFC1541
Protocol support by pump : ?????

-- My Command : dhcpcd -d eth0

-- while running ifconfig gives 
eth0      Lien encap:Ethernet  HWaddr 00:60:97:DD:5E:53  
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:100 
          RX bytes:0 (0.0 b)  TX bytes:18880 (18.4 Kb)
          Interruption:12 Adresse de base:0x220 

lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:38 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:4672 (4.5 Kb)  TX bytes:4672 (4.5 Kb)

-- end of dhcpcd
dhcpcd: MAC address = 00:60:97:dd:5e:53

-- now ifconfig gives
lo        Lien encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:38 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:4672 (4.5 Kb)  TX bytes:4672 (4.5 Kb)

-- I try with pump
I got the same ifconfig results
Error message : Operation failed
Technical Details
Message-ID: <Xns929E9EEB26FEFcyrilraphanelnetcour@193.229.0.31>
Path: arc1-ca.pugleaf.net!archiver1.google.com!news1.google.com!newsfeed.stanford.edu!news.tele.dk!small.news.tele.dk!195.25.12.36!oleane.net!oleane!News.neptune.fr!not-for-mail

Show Full Headers
Complete Article Headers
X-Google-Language: ENGLISH,ASCII-7-bit
X-Google-Thread: 10669a,61c8a3b24c43394b,start
X-Google-Attributes: gid10669a,public
X-Google-Thread: f8ece,61c8a3b24c43394b,start
X-Google-Attributes: gidf8ece,public
X-Google-ArrivalTime: 2002-10-05 06:01:02 PST
X-Original-Received: from chx400.switch.ch (chx400.switch.ch
    [130.59.10.2]) by Titan.neptune.fr (8.11.6/8.11.6) with ESMTP id
    g95Cbd224975 for <fcolc@neptune.fr>; Sat, 5 Oct 2002 14:37:39 +0200
X-Original-Received: from smtp31.kolumbus.fi ([193.229.0.36]) by
    chx400.switch.ch with esmtp (Exim 3.20 #1) id 17xoBe-0007TZ-00 for
    fr-comp-os-linux-configuration@moderators.isc.org; Sat, 05 Oct 2002
    14:37:38 +0200
X-Original-Received: from news.kolumbus.fi (news.kolumbus.fi
    [193.229.0.31]) by smtp31.kolumbus.fi (8.12.4/8.12.4) with ESMTP id
    g95Cbb5B027966 for <fr-comp-os-linux-configuration@moderators.isc.org>;
    Sat, 5 Oct 2002 15:37:37 +0300 (EEST)
X-Original-Received: (from news@localhost) by news.kolumbus.fi
    (8.11.6+Sun/8.11.6) id g95Cba402175 for
    fr-comp-os-linux-configuration@moderators.isc.org; Sat, 5 Oct 2002
    15:37:36 +0300 (EEST)
From: Cyril Raphanel <cyril.raphanel@netcourrier.com>
Newsgroups: comp.os.linux.networking,fr.comp.os.linux.configuration
Subject: LINUX-DHCP-ADSL-Connection
Organization: Your Company
Message-ID: <Xns929E9EEB26FEFcyrilraphanelnetcour@193.229.0.31>
X-Trace: phys-news1.kolumbus.fi 1033821456 1410 62.248.250.11 (5 Oct 2002
    12:37:36 GMT)
X-Complaints-To: abuse@kolumbus.fi
X-MailScanner: Found to be clean
X-Modappbot-Status: autoposted
X-Original-Path: not-for-mail
X-Original-Return-Path: <mail@Titan.neptune.fr>
X-Original-User-Agent: Xnews/5.04.25
X-Original-NNTP-Posting-Host: a11d31.elisa.omakaista.fi
X-Original-NNTP-Posting-Date: Sat, 5 Oct 2002 12:37:36 +0000 (UTC)
X-Original-Date: Sat, 5 Oct 2002 12:37:36 +0000 (UTC)
Path: arc1-ca.pugleaf.net!archiver1.google.com!news1.google.com!newsfeed.stanford.edu!news.tele.dk!small.news.tele.dk!195.25.12.36!oleane.net!oleane!News.neptune.fr!not-for-mail
Sender: fcolc-admin@neptune.fr
Approved: fcolc@neptune.fr
X-Modappbot-Version: 0.4.4
Date: 05 Oct 2002 12:45:01 GMT
Lines: 58