Thread View: comp.protocols.misc
2 messages
2 total messages
Started by Tait Cyrus
Sat, 01 Oct 1988 03:50
802.2 DSAP/SSAP assignments
Author: Tait Cyrus
Date: Sat, 01 Oct 1988 03:50
Date: Sat, 01 Oct 1988 03:50
31 lines
1291 bytes
1291 bytes
Before I call IEEE, I was wondering if anyone had a more detailed
list of the 802.2 Link Service Access Points than are listed in
RFC 1010. Currently the RFC has:
00 Null LSAP
02 Indiv LLC Sublayer Mgt
03 Group LLC Sublayer Mgt
04 SNA Path Control
06 DOD IP
0E PROWAY-LAN
4E EIA-RS 511
8E PROWAY-LAN
AA SNAP
FE ISO DIS 8473
FF Global DSAP
The RFC says, "these numbers (and others) are assigned by IEEE....".
My question is what are these "other numbers", or are they
confidinial as are the 48-bit MAC address :^)
Thanks. I will post a summary, assuming I get any replies :^)
---
@__________@ W. Tait Cyrus (505) 277-0806
/| /| University of New Mexico
/ | / | Dept of ECE - Parallel Processing Research Group
@__|_______@ | Albuquerque, New Mexico 87131
| | | |
| | hc | | e-mail:
| @.......|..@ cyrus@pprg.unm.edu
| / | /
@/_________@/
Re: 802.2 DSAP/SSAP assignments
Author: Rob Warnock
Date: Wed, 05 Oct 1988 07:41
Date: Wed, 05 Oct 1988 07:41
70 lines
3422 bytes
3422 bytes
In article <23647@hi.unm.edu> cyrus@hi.unm.edu (Tait Cyrus) writes:
+---------------
| Before I call IEEE, I was wondering if anyone had a more detailed
| list of the 802.2 Link Service Access Points than are listed in
| RFC 1010. Currently the RFC has:
| ... 06 DOD IP
| AA SNAP ...
+---------------
NOTA BENE: The use of the "06" LSAP/DSAP is deprecated, in favor of the
SNAP-based scheme described in RFC 1042, which gives you the full 16-bit
Ethernet types, not just "IP". (This is primarily because the IEEE committee
wouldn't allocate a bunch of other types for the other link-level things
we all know and love on Ethernet and feel are needed for a useful IP suite:
ARP, RARP, BOOTP, etc.)
In fact, in RFC 1010, just after the table you mention, is the following
section:
Due to some evolution of the IEEE 802.2 standards and the need to
provide for a standard way to do additional DoD-IP related protocols
(such as the Address Resolution Protocol (ARP) on IEEE 802 network,
the following new policy is established, which will replace the old
policy (see RFC 960 and RFC 948 [108]).
The new policy is for the Internet community to use the IEEE 802.2
encapsulation on 802.3, 802.4, and 802.5 networks by using the SNAP
with an organization code indicating that the following 16 bits
specify the EtherType code (where IP = 2048 (0800 hex), see Ethernet
Numbers of Interest).
Header
...--------+--------+--------+
MAC Header| Length | 802.{3/4/5} MAC
...--------+--------+--------+
+--------+--------+--------+
| Dsap=K1| Ssap=K1| control| 802.2 SAP
+--------+--------+--------+
+--------+--------+---------+--------+--------+
|protocol id or org code =K2| Ether Type | 802.2 SNAP
+--------+--------+---------+--------+--------+
The total length of the SAP Header and the SNAP header is 8-octets,
making the 802.2 protocol overhead come out on a nice boundary.
K1 is 170. The IEEE likes to talk about things in little-endian bit
transmission order and specifies this value as 01010101. In
big-endian order, as used in Internet specifications, this becomes
10101010 binary, or AA hex, or 170 decimal.
K2 is 0 (zero).
The use of the IP LSAP (K1 = 6) is to be phased out as quickly as
possible.
This change was initiated several years ago at the first TCP/IP Interoperability
Conference in Monterey, CA. As far as I know, no one but H-P is still using
the IP LSAP (and they may have quit by now). Similarly, virtually no one is
actually using "802.3" framing; they're all using "Ethernet". The above scheme
*is* being used on 802.5 token rings, and is already in use by some people on
FDDI.
Rob Warnock
Systems Architecture Consultant
UUCP: {amdcad,fortune,sun}!redwood!rpw3
ATTmail: !rpw3
DDD: (415)572-2607
USPS: 627 26th Ave, San Mateo, CA 94403
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads