๐Ÿš€ go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: fj.net.mime
Article #248

Handling linear-white-space in MIME part3 (Re: Tips for E-Mail ver 6.0beta)

#248
From: ็จฒๆ‘ ้›„ =JANE=
Date: Thu, 19 Dec 1996 00:00
38 lines
2097 bytes
>>In article <KATE.96Dec16134809@yamato.trad.pfu.co.jp>,
>>	kate@pfu.co.jp (KATAYAMA Yoshio)-san writes:

KY> โ€œๅพฉๅทใ™ใ‚‹ใจไฝ™ๅˆ†ใช็ฉบ็™ฝใŒๅŠ ใ‚ใ‚‹โ€ใจใ„ใ†ใ“ใจใฏใ€RFC 1342 ใฎ 

> Use of encoded-words in message headers
KY> ๏ผˆ็œ็•ฅ๏ผ‰
> When
> displaying a particular header field" (in the RFC 822 sense)
> containing one or more encoded-words, an unencoded SPACE character
> that immediately follows the encoded-word is not displayed.

KY> ใฏๆ—ขใซ็„กๅŠนใซใชใฃใฆใ„ใ‚‹ใจใ„ใ†ใ“ใจใงใ—ใ‚‡ใ†ใ‹๏ผŸ

ใใ†ใงใ™ใ€‚

ใ“ใฎ่พบใ‚Šใฏๆœ€ๆ–ฐใฎ RFC 2047 ใงใฏ (ๅฎŸ้š›ใฏใ™ใงใซ RFC 1522 ใฎ้ ƒใ‹
ใ‚‰ๅŒๆง˜ใซ)

   When displaying a particular header field that contains multiple
   'encoded-word's, any 'linear-white-space' that separates a pair of
   adjacent 'encoded-word's is ignored.  (This is to allow the use of
   multiple 'encoded-word's to represent long strings of unencoded text,
   without having to separate 'encoded-word's where spaces occur in the
   unencoded text.)

ใฎใ‚ˆใ†ใซๅค‰ใฃใฆใ„ใฆใ€encoded-word ใซๆŒŸใพใ‚ŒใŸ linear-white-space 
ใฎใฟใ‚’็„ก่ฆ–ใ™ใ‚‹ใ‚ˆใ†ใซใชใ‚Šใพใ—ใŸใ€‚็†็”ฑใฏๆ‹ฌๅผงใฎไธญใซ่จ˜ใ•ใ‚ŒใŸ้€šใ‚Š
ใงใ™ใ€‚


ๅŒๆง˜ใซใ€encoded-word ใจๆ™ฎ้€šใฎ text ใซๆŒŸใพใ‚ŒใŸ็ฉบ็™ฝใ‚‚็„ก่ฆ–ใ—ใฆ
ใใ‚Œใ‚‹ใ‚ˆใ†ใซใชใฃใฆใ„ใ‚Œใฐๅ•้กŒใชใ‹ใฃใŸใ‚“ใงใ™ใŒใ€ใ“ใ†ใ™ใ‚‹ใจ (ใŸ
ใถใ‚“) "Q" encode ใ—ใŸ ISO-8859-* ็ณปใฎๆ–‡ๅญ—ใจ US-ASCII text ใ‚’
ๆททๅœจใ•ใ›ใ‚‹้š›ใฎ็ฉบ็™ฝใฎๆ‰ฑใ„ใŒๅซŒใ ใฃใŸใ‚“ใงใ—ใ‚‡ใ†ใญใ€‚
--
็จฒๆ‘ ้›„ =JANE=
Technical Details
Message-ID: <INAMURA.96Dec19123910@caesar.ats.nis.nec.co.jp>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <KATE.96Dec16134809@yamato.trad.pfu.co.jp>

Show Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS
X-Google-Thread: 100bbf,14e7054fa3f8d227
X-Google-Attributes: gid100bbf,public
From: inamura@ats.nis.nec.co.jp (็จฒๆ‘ ้›„  =JANE=)
Subject: Handling linear-white-space in MIME part3 (Re: Tips for E-Mail ver 6.0beta)
Date: 1996/12/19
Message-ID: <INAMURA.96Dec19123910@caesar.ats.nis.nec.co.jp>
X-Deja-AN: 205420704
references: <KATE.96Dec16134809@yamato.trad.pfu.co.jp>
content-type: text/plain; charset=ISO-2022-JP
organization: NEC Informatec Systems, Ltd.
mime-version: 1.0
newsgroups: fj.net.mime