Thread View: fj.net.mime
3 messages
3 total messages
Started by Kaizou Nakao
Fri, 06 Feb 1998 00:00
[Q] MIME content-type Naming rule ?
Author: Kaizou Nakao
Date: Fri, 06 Feb 1998 00:00
Date: Fri, 06 Feb 1998 00:00
21 lines
1197 bytes
1197 bytes
$BCfHx$H?=$7$^$9!#(B fj.net.mime$B$H!"(Bfj.mail$B$N%/%m%9%]%9%H$G$9!#(B Followup-to$B$O;XDj$7$F$J$$$N$G!"ESCf$G$I$A$i$+$U$5$o$7$$J}$K$D$1$F2<$5$$!#(B JEPRO$B$N(BWinYAT32 ver.3$B$H$$$&%a!<%k%=%U%H$r;H$C$F$$$^$9!#(B $B$3$N%=%U%H$O(BMIME$B$N<oJL(B(Comment$B$H(BContent-Type)$B$r<+J,$G@_Dj$9$k$h$&$K$J$C(B $B$F$$$^$9!#(B $BNc$($P!"(BMS-Word$B$NJ8=q$r07$&$H$7$?$i!"(B Comment$B$K(B MS-Word document Content-Type$B$K(B Application/MS-Word $B$H$$$&46$8$K;XDj$7$^$9!#(B $B$=$3$G5?Ld$K;W$C$?$N$G$9$,!"(BContent-Type$B$NL?L>5,B'$O(BRFC$B$J$I$G;X?K$,<($5(B $B$l$F$$$k$N$G$7$g$&$+!)(B $B$J$K$+;29M$H$J$kJ88%Ey$"$j$^$7$?$i>R2p$7$F2<$5$$!#(B
Re: [Q] MIME content-type Naming rule ?
Author: FUJIMOTO Kou
Date: Fri, 06 Feb 1998 00:00
Date: Fri, 06 Feb 1998 00:00
55 lines
3142 bytes
3142 bytes
藤本@東工大です。
kaizou@ips.ntts.co.jp (Kaizou Nakao) writes:
> fj.net.mimeと、fj.mailのクロスポストです。
> Followup-toは指定してないので、途中でどちらかふさわしい方につけて下さい。
うーん、いまちょっと思い付かないのでそのまま:-)
> JEPROのWinYAT32 ver.3というメールソフトを使っています。
> このソフトはMIMEの種別(CommentとContent-Type)を自分で設定するようになっ
> ています。
コメント用のヘッダは "Comments:" ですね。
> 例えば、MS-Wordの文書を扱うとしたら、
> Commentに MS-Word document
> Content-Typeに Application/MS-Word
>
> という感じに指定します。
>
> そこで疑問に思ったのですが、Content-Typeの命名規則はRFCなどで指針が示さ
> れているのでしょうか?
RFC2045~2049までが、おそらくMIMEに関する最新のRFC文書です。
この中で、Content-Type に指定できるのは RFC2046 で規定された
トップレベルのメディアタイプと、IANAに登録されたもの、および
"x-" で始まる(非標準の)ものだという風に書いてあります。
IANAに登録されていないもので、とりあえず使いたいようなメディア
タイプがあるならば、application/x-hogehoge のように書くのが
よろしい、ということになるのだと思います。
#もちろん、application/x-hogehoge を受信側が理解できなければ
#無駄なんですが。
IANAに登録されているメディアタイプの一覧は
ftp://ftp.isi.edu/in-notes/iana/assignments/media-types/
で見ることができます。Microsoft Word のメディアタイプすでに
登録されていて、"application/msword" だそうです。
RFC2048には、登録に関わる説明が書かれていますが、そこでは
特定ベンダが用いるようなメディアタイプは vnd.<メディア名> で
いくのがよろしいみたいな話があります。実際、同じMSでも
Excelのメディアタイプは "application/vnd.ms-excel" です。
mswordが登録されたのは、こういう話が出てくる前だったのでしょうかね。
ちなみに、Outlook 何ちゃらいうソフトから application/ms-tnef
とかいうメディアタイプを持ったメールを送り付けられることが
たまにありますが、IANAに登録されてないんですよね。
#登録されているのは "application/vnd.ms-tnef" 。
#"vnd." を略してもよい、ってことは無いんですよねえ、確か。
--------
FUJIMOTO Kou, Network Operation Center, Tokyo Institute of Technology
fujimoto@noc.titech.ac.jp
Re: [Q] MIME content-type Naming rule ?
Author: TATEOKA Takamichi
Date: Fri, 06 Feb 1998 00:00
Date: Fri, 06 Feb 1998 00:00
36 lines
1940 bytes
1940 bytes
In article <KAIZOU.98Feb6114007@ipsgw.ips.ntts.co.jp> kaizou@ips.ntts.co.jp (Kaizou Nakao) writes: > JEPRO$B$N(BWinYAT32 ver.3$B$H$$$&%a!<%k%=%U%H$r;H$C$F$$$^$9!#(B > $B$3$N%=%U%H$O(BMIME$B$N<oJL(B(Comment$B$H(BContent-Type)$B$r<+J,$G@_Dj$9$k$h$&$K$J$C(B > $B$F$$$^$9!#(B > > $BNc$($P!"(BMS-Word$B$NJ8=q$r07$&$H$7$?$i!"(B > Comment$B$K(B MS-Word document > Content-Type$B$K(B Application/MS-Word > > $B$H$$$&46$8$K;XDj$7$^$9!#(B $B$3$l$O!"?7$7$$(B Content-Type: $B$,A}$($?;~$KBP=h$G$-$k$h$&$K$J$C$F$$$k(B $B$G$7$g$&$M!#(B > $B$=$3$G5?Ld$K;W$C$?$N$G$9$,!"(BContent-Type$B$NL?L>5,B'$O(BRFC$B$J$I$G;X?K$,<($5(B > $B$l$F$$$k$N$G$7$g$&$+!)(B RFC2046 Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types. N. Freed & N. Borenstein. November 1996. (Format: TXT=105854 bytes) (Obsoletes RFC1521, RFC1522, RFC1590) (Status: DRAFT STANDARD) $B$G$O$J$$$G$7$g$&$+!#$"$H!"?7$7$$%?%$%W$J$I$NEPO?$K4X$7$F$O!"(B RFC2048 Multipurpose Internet Mail Extensions (MIME) Part Four: Registration Procedures. N. Freed, J. Klensin & J. Postel. November 1996. (Format: TXT=45033 bytes) (Obsoletes RFC1521, RFC1522, RFC1590) (Also BCP0013) (Status: BEST CURRENT PRACTICE) $B$@$H;W$$$^$9!#(B -- $BEE5$DL?.Bg3X(B MMA($B%^%$%/%m%3%s%T%e!<%?$r:n$k2q(B) $B=]2,9'F;(B (tree) tate@spa.is.uec.ac.jp
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads