Thread View: fj.net.mime
6 messages
6 total messages
Started by toda
Fri, 01 Jun 2001 03:06
Encode by Each Character
Author: toda
Date: Fri, 01 Jun 2001 03:06
Date: Fri, 01 Jun 2001 03:06
36 lines
2241 bytes
2241 bytes
$BK?9qN)AH?%$+$iEv4[$X(B
Subject$B%U%#!<%k%I$,0J2<$N$h$&$K%(%s%3!<%I$5$l$?%a!<%k$,Mh$^$7$?!#(B
$B!a!a!a!a!a!a!a!a$3$3$+$i!a!a!a!a!a!a!a!a(B
Subject: =?ISO-2022-JP?B?GyRCJVsbKEI=?=
=?ISO-2022-JP?B?GyRCITwbKEI=?=
=?ISO-2022-JP?B?GyRCJWAbKEI=?=
=?ISO-2022-JP?B?GyRCJVobKEI=?=
=?ISO-2022-JP?B?GyRCITwbKEI=?=
=?ISO-2022-JP?B?GyRCJTgbKEI=?=
=?ISO-2022-JP?B?GyRCJE4bKEI=?=
=?ISO-2022-JP?B?GyRCJWobKEI=?=
=?ISO-2022-JP?B?GyRCJXMbKEI=?=
=?ISO-2022-JP?B?GyRCJS8bKEI=?=
=?ISO-2022-JP?B?GyRCNXYbKEI=?=
=?ISO-2022-JP?B?GyRCMkQbKEI=?=
=?ISO-2022-JP?B?GyRCJEsbKEI=?=
=?ISO-2022-JP?B?GyRCNFgbKEI=?=
=?ISO-2022-JP?B?GyRCJDcbKEI=?=
=?ISO-2022-JP?B?GyRCJEYbKEI=?=
$B!a!a!a!a!a!a!a!a$3$3$^$G!a!a!a!a!a!a!a!a(B
$B5-;v$N9T$,D9$/$J$k$N$H!"FI$_$K$/$/$J$k$N$H$rKI$0$?$a2~9T$rF~$l$^$7$?$,!"(B
$B%*%j%8%J%k$O(B
$B!V(B=?ISO-2022-JP?B?GyRCJVsbKEI=?==?ISO-2022-JP?B?GyRCITwbKEI=?==? $B!D!D!W(B
$B$H$$$&6q9g$K1d!9$D$J$,$C$?(B489$B%P%$%H$N#1$D$N9T$G$9!#(B
$B!J$3$l$C$FD9$5>r7o$K0cH?$7$F$^$9$h$M!K(B
$BMW$9$k$K!V%[!<%`%Z!<%8$N%j%s%/5v2D$K4X$7$F!W$H$$$&J8;zNs$r(B
$B#1J8;z$:$DJ,2r$7$F!"3F!9$r=j0b!V4A;z(BIN$B!W$H=j0b!V4A;z(BOUT$B!W$G64$_!"(B
$B3F!9JL!9$K(BMIME$B$NJ}<0$G%(%s%3!<%I$7$?$o$1$G$9!#(B
$B%a!<%k%X%C%@$K$O;HMQ%=%U%H$K4X$9$k>pJs$O8+Ev$?$i$J$+$C$?$N$G$9$,!"(B
$B0lBN$I$&$$$&%=%U%H$,$3$&$$$&JQ$F$3$J%(%s%3!<%I$r$9$k$s$G$7$g$&$M!)(B
$B8MED(B $B9'!w<"2l8)N)H|GJ8PGnJ*4[(B
toda@lbm.go.jp
Re: Encode by Each Character
Author: Takao Ono
Date: Fri, 01 Jun 2001 04:18
Date: Fri, 01 Jun 2001 04:18
19 lines
1985 bytes
1985 bytes
$B>.Ln(B@$BL>8E20Bg3X(B $B$G$9(B. <9f70r0$iao@nws-7000.lbm.go.jp>$B$N5-;v$K$*$$$F(B toda@lbm.go.jp$B$5$s$O=q$-$^$7$?!#(B toda> $B5-;v$N9T$,D9$/$J$k$N$H!"FI$_$K$/$/$J$k$N$H$rKI$0$?$a2~9T$rF~$l$^$7$?$,!"(B toda> $B%*%j%8%J%k$O(B toda> $B!V(B=?ISO-2022-JP?B?GyRCJVsbKEI=?==?ISO-2022-JP?B?GyRCITwbKEI=?==? $B!D!D!W(B toda> $B$H$$$&6q9g$K1d!9$D$J$,$C$?(B489$B%P%$%H$N#1$D$N9T$G$9!#(B toda> $B!J$3$l$C$FD9$5>r7o$K0cH?$7$F$^$9$h$M!K(B RFC2822 $B$K$$$o$/(B Each line of characters MUST be no more than 998 characters, and SHOULD be no more than 78 characters, excluding then CRLF. $B$G$9$+$i(B, $BD9$5$N@)8B$K0cH?$7$F$$$k$o$1$G$O$J$$$G$9(B. $B$b$C$H$b(B, $B$3$N$h$&$K$D$J$2$k$H$-$K$O6uGr$rF~$l$k$H$+(B, $B$=$&$$$&@)(B $BLs$,(B MIME $B$H$+$NJ}$K$"$j$^$;$s$G$7$?$C$1(B? -- $BL>8E20Bg3X(B $B9)3XIt(B $BEE;R9)3X2J(B $BJ?ED8&5f<<(B $B>.Ln(B $B9'CK(B
Re: Encode by Each Character
Author: Mori Kouji
Date: Fri, 01 Jun 2001 05:00
Date: Fri, 01 Jun 2001 05:00
29 lines
2645 bytes
2645 bytes
takao@hirata.nuee.nagoya-u.ac.jp (Takao Ono) writes: > toda> オリジナルは > toda> 「=?ISO-2022-JP?B?GyRCJVsbKEI=?==?ISO-2022-JP?B?GyRCITwbKEI=?==? ……」 > toda> という具合に延々つながった489バイトの1つの行です。 > toda> (これって長さ条件に違反してますよね) > RFC2822 にいわく > Each line of characters MUST be no more than 998 characters, and > SHOULD be no more than 78 characters, excluding then CRLF. > ですから, 長さの制限に違反しているわけではないです. RFC2047 の An 'encoded-word' may not be more than 75 characters long, including 'charset', 'encoding', 'encoded-text', and delimiters. If it is desirable to encode more text than will fit in an 'encoded-word' of 75 characters, multiple 'encoded-word's (separated by CRLF SPACE) may be used. While there is no limit to the length of a multiple-line header field, each line of a header field that contains one or more 'encoded-word's is limited to 76 characters. は関係してきませんか? -- 森 浩二 (MORI Kouji) (株)淺沼組 技術研究所 E-mail: mori@tri.asanuma.co.jp
Re: Encode by Each Character
Author: HAT
Date: Fri, 01 Jun 2001 05:53
Date: Fri, 01 Jun 2001 05:53
17 lines
1546 bytes
1546 bytes
> 要するに「ホームページのリンク許可に関して」という文字列を > 1文字ずつ分解して、各々を所謂「漢字IN」と所謂「漢字OUT」で挟み、 > 各々別々にMIMEの方式でエンコードしたわけです。 > > メールヘッダには使用ソフトに関する情報は見当たらなかったのですが、 > 一体どういうソフトがこういう変てこなエンコードをするんでしょうね? かなり前にテストしたときの記憶では、 letters http://www.HyperRockets.com/letters/ が、1文字づつエンコードして、間にスペースを入れていませんでした。 1行になってたかどうかは覚えていない。 X-Mailerヘッダがついてたかどうかは、忘れた。 -- HAT <hat@fa2.so-net.ne.jp>
Re: Encode by Each Character
Author: Takao Ono
Date: Fri, 01 Jun 2001 07:01
Date: Fri, 01 Jun 2001 07:01
24 lines
2229 bytes
2229 bytes
$B>.Ln(B@$BL>8E20Bg3X(B $B$G$9(B. <80r8x4sska.fsf@kurishna.tri.asanuma.co.jp>$B$N5-;v$K$*$$$F(B mori@tri.asanuma.co.jp$B$5$s$O=q$-$^$7$?!#(B mori> > toda> $B%*%j%8%J%k$O(B mori> > toda> $B!V(B=?ISO-2022-JP?B?GyRCJVsbKEI=?==?ISO-2022-JP?B?GyRCITwbKEI=?==? $B!D!D!W(B mori> > RFC2822 $B$K$$$o$/(B mori> RFC2047 $B$N(B mori> 'charset', 'encoding', 'encoded-text', and delimiters. If it is mori> desirable to encode more text than will fit in an 'encoded-word' of mori> 75 characters, multiple 'encoded-word's (separated by CRLF SPACE) may mori> be used. mori> mori> While there is no limit to the length of a multiple-line header mori> field, each line of a header field that contains one or more mori> 'encoded-word's is limited to 76 characters. mori> $B$O4X78$7$F$-$^$;$s$+(B? $B$*$)(B ($B%]%s(B). $B%(%s%3!<%I$5$l$F$k$+$i(B, $B8e$m$N(B 76$BJ8;z$N@)8B$NJ}$,8z(B $B$$$F$-$^$9$M(B. $B<:Ni$7$^$7$?(B. -- $BL>8E20Bg3X(B $B9)3XIt(B $BEE;R9)3X2J(B $BJ?ED8&5f<<(B $B>.Ln(B $B9'CK(B
Re: Encode by Each Character
Author: ASADA Kazuhisa
Date: Fri, 01 Jun 2001 11:44
Date: Fri, 01 Jun 2001 11:44
38 lines
2354 bytes
2354 bytes
フォロー先を fj.net.mime に絞ります。
Mori Kouji <mori@tri.asanuma.co.jp> さんは、
<80r8x4sska.fsf@kurishna.tri.asanuma.co.jp> に書きました:
> RFC2047 の
~略~
> は関係してきませんか?
それに加えて、同じく RFC2047 にある
(1) An 'encoded-word' may replace a 'text' token (as defined by RFC 822)
in any Subject or Comments header field, any extension message
header field, or any MIME body part field for which the field body
is defined as '*text'. An 'encoded-word' may also appear in any
user-defined ("X-") message or body part header field.
Ordinary ASCII text and 'encoded-word's may appear together in the
same header field. However, an 'encoded-word' that appears in a
header field defined as '*text' MUST be separated from any adjacent
'encoded-word' or 'text' by 'linear-white-space'.
も関係するのではないでしょうか。
つまり、
Subject: =?ISO-2022-JP?B?GyRCJVsbKEI=?==?ISO-2022-JP?B?G~~~
はダメで、
Subject: =?ISO-2022-JP?B?GyRCJVsbKEI=?=
=?ISO-2022-JP?B?GyRCITwbKEI=?=
=?ISO-2022-JP?B?GyRCJWAbKEI=?=
~~
ならば良いと。
--
浅田和久/大阪市在住
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads