🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

21 total messages Started by John Gilmore Wed, 29 Apr 1987 22:12
RFC 989: Privacy Enhancement for Internet Electronic Mail
#3530
Author: John Gilmore
Date: Wed, 29 Apr 1987 22:12
1362 lines
64853 bytes
[Please send followups to EITHER sci.crypt or comp.mail.misc, depending
whether you are talking about cryptographic issues or mailer issues.]


Network Working Group                                   John Linn (BBNCC)
Request for Comments: 989                          IAB Privacy Task Force
                                                            February 1987


           Privacy Enhancement for Internet Electronic Mail:
       Part I: Message Encipherment and Authentication Procedures


STATUS OF THIS MEMO

   This RFC suggests a proposed protocol for the Internet community and
   requests discussion and suggestions for improvements.  Distribution
   of this memo is unlimited.

ACKNOWLEDGMENT

   This RFC is the outgrowth of a series of IAB Privacy Task Force
   meetings and of internal working papers distributed for those
   meetings.  I would like to thank the following Privacy Task Force
   members and meeting guests for their comments and contributions at
   the meetings which led to the preparation of this RFC: David
   Balenson, Matt Bishop, Danny Cohen, Tom Daniel, Charles Fox, Morrie
   Gasser, Steve Kent (chairman), John Laws, Steve Lipner, Dan Nessett,
   Mike Padlipsky, Rob Shirey, Miles Smid, Steve Walker, and Steve
   Wilbur.

1  Executive Summary

   This RFC defines message encipherment and authentication procedures,
   as the initial phase of an effort to provide privacy enhancement
   services for electronic mail transfer in the Internet.  Detailed key
   management mechanisms to support these procedures will be defined in
   a subsequent RFC.  As a goal of this initial phase, it is intended
   that the procedures defined here be compatible with a wide range of
   key management approaches, including both conventional (symmetric)
   and public-key (asymmetric) approaches for encryption of data
   encrypting keys.  Use of conventional cryptography for message text
   encryption and/or authentication is anticipated.

   Privacy  enhancement services (confidentiality, authentication, and
   message integrity assurance) are offered through the use of end-to-
   end cryptography between originator and recipient User Agent
   processes, with no special processing requirements imposed on the
   Message Transfer System at endpoints or at intermediate relay sites.
   This approach allows privacy enhancement facilities to be
   incorporated on a site-by-site or user-by-user basis without impact
   on other Internet entities.  Interoperability among heterogeneous
   components and mail transport facilities is supported.





Linn, Privacy Task Force                                        [Page 1]

RFC 989                                                    February 1987


2  Terminology

   For descriptive purposes, this RFC uses some terms defined in the OSI
   X.400 Message Handling System Model.  This section replicates a
   portion of X.400's Section 2.2.1, "Description of the MHS Model:
   Overview" in order to make the terminology clear to readers who may
   not be familiar with the OSI MHS Model.

   In the [MHS] model, a user is a person or a computer application.  A
   user is referred to as either an originator (when sending a message)
   or a recipient (when receiving one).  MH Service elements define the
   set of message types and the capabilities that enable an originator
   to transfer messages of those types to one or more recipients.

   An originator prepares messages with the assistance of his User
   Agent.  A User Agent (UA) is an application process that interacts
   with the Message Transfer System (MTS) to submit messages.  The MTS
   delivers to one or more recipient UAs the messages submitted to it.
   Functions performed solely by the UA and not standardized as part of
   the MH Service elements are called local UA functions.

   The MTS is composed of a number of Message Transfer Agents (MTAs).
   Operating together, the MTAs relay messages and deliver them to the
   intended recipient UAs, which then make the messages available to the
   intended recipients.

   The collection of UAs and MTAs is called the Message Handling System
   (MHS).  The MHS and all of its users are collectively referred to as
   the Message Handling Environment.

3  Services, Constraints, and Implications

   This RFC's goal is to define mechanisms to enhance privacy for
   electronic mail transferred in the Internet.  The facilities
   discussed in this RFC provide privacy enhancement services on an
   end-to-end basis between sender and recipient UAs.  No privacy
   enhancements are offered for message fields which are added or
   transformed by intermediate relay points.  Two distinct privacy
   enhancement service options are supported:

      1.  an option providing sender authentication and integrity
          verification

      2.  an option providing sender authentication and integrity
          verification in addition to confidentiality service through
          encryption

   No facility for confidentiality service in the absence of
   authentication is provided.  Encryption and authentication facilities
   may be applied selectively to portions of a message's contents; this
   allows less sensitive portions of messages (e.g., descriptive fields)



Linn, Privacy Task Force                                        [Page 2]

RFC 989                                                    February 1987


   to be processed by a recipient's delegate in the absence of the
   recipient's personal cryptographic keys.

   In keeping with the Internet's heterogeneous constituencies and usage
   modes, the measures defined here are applicable to a broad range of
   Internet hosts and usage paradigms.  In particular, it is worth
   noting the following attributes:


        1.   The mechanisms defined in this RFC are not restricted to a
             particular host or operating system, but rather allow
             interoperability among a broad range of systems.  All
             privacy enhancements are implemented at the application
             layer, and are not dependent on any privacy features at
             lower protocol layers.

        2.   The defined mechanisms offer compatibility with non-
             enhanced Internet components.  Privacy enhancements will be
             implemented in an end-to-end fashion which does not impact
             mail processing by intermediate relay hosts which do not
             incorporate privacy enhancement facilities.  It is
             necessary, however, for a message's sender to be cognizant
             of whether a message's intended recipient implements
             privacy enhancements, in order that encoding and possible
             encipherment will not be performed on a message whose
             destination is not equipped to perform corresponding
             inverse transformations.

        3.   The defined mechanisms offer compatibility with a range of
             mail transport facilities (MTAs).  Within the Internet,
             electronic mail transport is effected by a variety of SMTP
             implementations.  Certain sites, accessible via SMTP,
             forward mail into other mail processing environments (e.g.,
             USENET, CSNET, BITNET).  The privacy enhancements must be
             able to operate across the SMTP realm; it is desirable that
             they also be compatible with protection of electronic mail
             sent between the SMTP environment and other connected
             environments.

        4.   The defined mechanisms offer compatibility with a broad
             range of electronic mail user agents (UAs).  A large
             variety of electronic mail user agent programs, with a
             corresponding broad range of user interface paradigms, is
             used in the Internet.  In order that an electronic mail
             privacy enhancement be available to the broadest possible
             user community, it is desirable that the selected mechanism
             be usable with the widest possible variety of existing UA
             programs.  For purposes of pilot implementation, it is
             desirable that privacy enhancement processing be
             incorporable into a separate program, applicable to a range
             of UAs, rather than requiring internal modifications to



Linn, Privacy Task Force                                        [Page 3]

RFC 989                                                    February 1987


             each UA with which enhanced privacy services are to be
             provided.

        5.   The defined mechanisms allow electronic mail privacy
             enhancement processing to be performed on personal
             computers (PCs) separate from the systems on which UA
             functions are implemented.  Given the expanding use of PCs
             and the limited degree of trust which can be placed in UA
             implementations on many multi-user systems, this attribute
             can allow many users to process privacy-enhanced mail with
             a higher assurance level than a strictly UA-based approach
             would allow.

        6.   The defined mechanisms support privacy protection of
             electronic mail addressed to mailing lists.

   In order to achieve applicability to the broadest possible range of
   Internet hosts and mail systems, and to facilitate pilot
   implementation and testing without the need for prior modifications
   throughout the Internet, three basic restrictions are imposed on the
   set of measures to be considered in this RFC:


          1.   Measures will be restricted to implementation at
               endpoints and will be amenable to integration at the user
               agent (UA) level or above, rather than necessitating
               integration into the message transport system (e.g., SMTP
               servers).

          2.   The set of supported measures enhances rather than
               restricts user capabilities.  Trusted implementations,
               incorporating integrity features protecting software from
               subversion by local users, cannot be assumed in general.
               In the absence of such features, it appears more feasible
               to provide facilities which enhance user services (e.g.,
               by protecting and authenticating inter-user traffic) than
               to enforce restrictions (e.g., inter-user access control)
               on user actions.

          3.   The set of supported measures focuses on a set of
               functional capabilities selected to provide significant
               and tangible benefits to a broad user community.  By
               concentrating on the most critical set of services, we
               aim to maximize the added privacy value that can be
               provided with a modest level of implementation effort.

   As a result of these restrictions, the following facilities can be
   provided:

         -- disclosure protection,




Linn, Privacy Task Force                                        [Page 4]

RFC 989                                                    February 1987


         -- sender authenticity, and

         -- message integrity measures,

   but the following privacy-relevant concerns are not addressed:

         -- access control,

         -- traffic flow security,

         -- address list accuracy,

         -- routing control,

         -- issues relating to the serial reuse of PCs by multiple users,

         -- assurance of message receipt and non-deniability of receipt, and

         -- automatic association of acknowledgments with the messages to
            which they refer

   An important goal is that privacy enhancement mechanisms impose a
   minimum of burden on the users they serve.  In particular, this goal
   suggests eventual automation of the key management mechanisms
   supporting message encryption and authentication.  In order to
   facilitate deployment and testing of pilot privacy enhancement
   implementations in the near term, however, compatibility with out-
   of-band (e.g., manual) key distribution must also be supported.

   A message's sender will determine whether privacy enhancements are to
   be performed on a particular message.  This will necessitate
   mechanisms by which a sender can determine whether particular
   recipients are equipped to process privacy-enhanced mail.  In a
   general architecture, these mechanisms will be based on server
   queries; thus, the query function could be integrated into a UA to
   avoid imposing burdens or inconvenience on electronic mail users.

4  Processing of Messages

4.1  Message Processing Overview

   This subsection provides a high-level overview of the components and
   processing steps involved in electronic mail privacy enhancement
   processing.  Subsequent subsections will define the procedures in
   more detail.

   A two-level keying hierarchy is used to support privacy-enhanced
   message transmission:


     1.   Data Encrypting Keys (DEKs) are used for encryption of message



Linn, Privacy Task Force                                        [Page 5]

RFC 989                                                    February 1987


          text and for computation of message authentication codes
          (MACs).  DEKs are generated individually for each transmitted
          message; no predistribution of DEKs is needed to support
          privacy-enhanced message transmission.

     2.   Interchange Keys (IKs) are used to encrypt DEKs for
          transmission.  An IK may either be a single symmetric
          cryptographic key or, where asymmetric (public-key)
          cryptography is used for DEK encryption, the composition of a
          public component used by an originator and a secret component
          used by a recipient.  Ordinarily, the same IK will be used for
          all messages sent between a given originator-recipient pair
          over a period of time.  Each transmitted message includes a
          representation of the DEK(s) used for message encryption
          and/or authentication, encrypted under an individual IK per
          named recipient.  This representation is accompanied by an
          identifier (IK ID) to enable the recipient to determine which
          IK was used, and so to decrypt the representation yielding the
          DEK required for message text decryption and/or MAC
          verification.

   An encoding procedure is employed in order to represent encrypted
   message text in a universally transmissible form and to enable
   messages encrypted on one type of system to be decrypted on a
   different type.  Four phases are involved in this process.  A
   plaintext message is accepted in local form, using the host's native
   character set and line representation.  The local form is converted
   to a canonical message text representation, defined as equivalent to
   the inter-SMTP representation of message text.  The canonical
   representation is padded to an integral multiple of eight octets, as
   required by the encryption algorithm.  MAC computation is performed,
   and (if disclosure protection is required), the padded canonical
   representation is encrypted.  The output of this step is encoded into
   a printable form.  The printable form is composed of a restricted
   character set which is chosen to be universally representable across
   sites, and which will not be disrupted by processing within and
   between MTS entities.

   The output of the encoding procedure is combined with a set of header
   fields (to be defined in Section 4.8) carrying cryptographic control
   information.  The result is passed to the electronic mail system to
   be encapsulated as the text portion of a transmitted message.

   When a privacy-enhanced message is received, the cryptographic
   control fields within its text portion provide the information
   required for the authorized recipient to perform MAC verification and
   decryption on the received message text.  First, the printable
   encoding is converted to a bitstring.  If the transmitted message was
   encrypted, it is decrypted into the canonical representation.  If the
   message was not encrypted, decoding from the printable form produces
   the canonical representation directly.  The MAC is verified, and the



Linn, Privacy Task Force                                        [Page 6]

RFC 989                                                    February 1987


   canonical representation is converted to the recipient's local form,
   which need not be the same as the sender's local form.

4.2  Encryption Algorithms and Modes

   For purposes of this RFC, the Block Cipher Algorithm DEA-1, defined
   in ISO draft international standard DIS 8227 [1] shall be used for
   encryption of message text and for computation of authentication
   codes on messages.  The DEA-1 is equivalent to the Data Encryption
   Standard (DES), as defined in FIPS PUB 46 [2].  When used for these
   purposes, the DEA-1 shall be used in the Cipher Block Chaining (CBC)
   mode, as defined in ISO DIS 8372 [3].  The CBC mode definition in DIS
   8372 is equivalent to that provided in FIPS PUB 81 [4].  A unique
   initializing vector (IV) will be generated for and transmitted with
   each encrypted electronic mail message.

   An algorithm other than DEA-1 may be employed, provided that it
   satisfies the following requirements:

       1.  it must be a 64-bit block cipher, enciphering and deciphering
           in 8 octet blocks

       2.  it is usable in the ECB and CBC modes defined in DIS8372

       3.  it is able to be keyed using the procedures and parameters
           defined in this RFC

       4.  it is appropriate for MAC computation

       5.  cryptographic key field lengths are limited to 16 octets
           in length

   Certain operations require that one key be encrypted under another
   key (interchange key) for purposes of transmission.  For purposes of
   this RFC, such encryption will be performed using DEA-1 in Electronic
   Codebook (ECB) mode.  An optional facility is available to an
   interchange key provider to indicate that an associated key is to be
   used for encryption in another mode (e.g., the Encrypt-Decrypt-
   Encrypt (EDE) mode used for key encryption and decryption with pairs
   of 64-bit keys, as described [5] by ASC X3T1).

   Future support of public key algorithms for key encryption is under
   consideration, and it is intended that the procedures defined in this
   RFC be appropriate to allow such usage.  Support of key encryption
   modes other than ECB is optional for implementations, however.
   Therefore, in support of universal interoperability, interchange key
   providers should not specify other modes in the absence of a priori
   information indicating that recipients are equipped to perform key
   encryption in other modes.





Linn, Privacy Task Force                                        [Page 7]

RFC 989                                                    February 1987


4.3  Canonical Encoding

   Any encryption scheme must be compatible with the transparency
   constraints of its underlying electronic mail facilities.  These
   constraints are generally established based on expected user
   requirements and on the characteristics of anticipated endpoint
   transport facilities.  SMTP, designed primarily for interpersonal
   messages and anticipating systems and transport media which may be
   restricted to a 7-bit character set, can transmit any 7-bit
   characters (but not arbitrary 8-bit binary data) in message text.

   SMTP introduces other transparency constraints related to line
   lengths and message delimiters.  Message text may not contain the
   string "<CR><LF>.<CR><LF>" in sequence before the end of a message,
   and must contain the string "<CR><LF>" at least every 1000
   characters.  Another important SMTP transparency issue must be noted.
   Although SMTP specifies a standard representation for line delimiters
   (ASCII <CR><LF>), numerous systems use a different native
   representation to delimit lines.  For example, the <CR><LF> sequences
   delimiting lines in mail inbound to UNIX(tm) systems are transformed
   to single <LF>s as mail is written into local mailbox files.  Lines
   in mail incoming to record-oriented systems (such as VAX VMS) may be
   converted to appropriate records by the destination SMTP [6] server.
   As a result, if the encryption process generated <CR>s or <LF>s,
   those characters might not be accessible to a recipient UA program at
   a destination using different line delimiting conventions.  It is
   also possible that conversion between tabs and spaces may be
   performed in the course of mapping between inter-SMTP and local
   format; this is a matter of local option.  If such transformations
   changed the form of transmitted ciphertext, decryption would fail to
   regenerate the transmitted plaintext, and a transmitted MAC would
   fail to compare with that computed at the destination.

   The conversion performed by an SMTP server at a system with EBCDIC as
   a native character set has even more severe impact, since the
   conversion from EBCDIC into ASCII is an information-losing
   transformation.  In principle, the transformation function mapping
   between inter-SMTP canonical ASCII message representation and local
   format could be moved from the SMTP server up to the UA, given a
   means to direct that the SMTP server should no longer perform that
   transformation.  This approach has the disadvantage that it would
   imply internal file (e.g., mailbox) formats which would be
   incompatible with the systems on which they reside, an untenable
   prospect.  Further, it would require modification to SMTP servers, as
   mail would be passed to SMTP in a different representation than it is
   passed at present.

   Our approach to this problem selects a canonical character set,
   uniformly representable across privacy-enhanced UAs regardless of
   their systems' native character sets, to transport encrypted mail
   text (but not electronic mail transport headers!) between endpoints.



Linn, Privacy Task Force                                        [Page 8]

RFC 989                                                    February 1987


   In this approach, an outbound privacy-enhanced message is transformed
   between four forms, in sequence:


     1.   (Local_Form) The message text is created (e.g., via an editor)
          in the system's native character set, with lines delimited in
          accordance with local convention.

     2.   (Canonicalize) The message text is converted to the universal
          canonical form, equivalent to the inter-SMTP representation as
          defined in RFC822 [7] (ASCII character set, <CR><LF> line
          delimiters).  (The processing required to perform this
          conversion is relatively small, at least on systems whose
          native character set is ASCII.)

     3.   (Encipher/Authenticate) A padded version of the canonical
          plaintext representation is created by appending zero-valued
          octets to the end of the representation until the length is an
          integral multiple of 8 octets, as is required to perform
          encryption in the DEA-1 CBC mode.  No padding is applied if
          the canonical plaintext representation's length is already a
          multiple of 8 octets.  This padded representation is used as
          the input to the encryption function and to the MAC
          computation function.

     4.   (Encode to Printable Form) The bits resulting from the
          encryption operation are encoded into characters which are
          universally representable at all sites, though not necessarily
          with the same bit patterns (e.g., although the character "E"
          is represented in an ASCII-based system as hexadecimal 45 and
          as hexadecimal C5 in an EBCDIC-based system, the local
          significance of the two representations is equivalent).  Use
          of a 64-character subset of International Alphabet IA5 is
          proposed, enabling 6 bits to be represented per printable
          character.  (The proposed subset of characters is represented
          identically in IA5 and ASCII.) Two additional characters, "="
          and "*", are used to signify special processing functions.
          The encoding function's output is delimited into text lines
          (using local conventions), with each line containing 64
          printable characters.  The encoding process is performed as
          follows, transforming strings of 3 arbitrary (8-bit)
          characters to strings of 4 encoded characters:

          4a.  Proceeding from left to right across the input characters
               (considered as a contiguous bitstring), each group of 6
               bits is used as an index into an array of 64 printable
               characters; the character referenced by the index is
               placed in the output string.  These characters,
               identified in Table 1, are selected so as to be
               universally representable, and the set excludes
               characters with particular significance to SMTP e.g.,



Linn, Privacy Task Force                                        [Page 9]

RFC 989                                                    February 1987


               ".", "<CR>", "<LF>").

          4b.  If fewer than 3 input characters are available in a final
               quantum, zero bits are added (on the right) to form an
               integral number of 6-bit groups.  Output character
               positions which are not required to represent actual
               input data are set to a 65th reserved, universally
               representable character ("=").  Use of a reserved
               character for padding allows compensatory processing to
               be performed by a recipient, allowing the decoded message
               text's length to be precisely the same as the input
               message's length.  A final 3-octet input quantum will be
               represented as a 4 octet encoding with no terminal "=", a
               2-octet input quantum will be represented as 3 octets
               followed by one terminal "=", and a 1-octet input quantum
               will be represented as 2 octets followed by two
               occurrences of "=".

   A sender may exclude one or more portions of a message from
   encryption/authentication processing.  Explicit action is required to
   exclude a portion of a message from such processing; by default,
   encryption/authentication is applied to the entirety of message text.
   The user-level delimiter which specifies such exclusion is a local
   matter, and hence may vary between sender and recipient, but all
   systems should provide a means for unambiguous  identification of
   areas excluded from encryption/authentication processing.  An
   excluded area is represented in the inter-SMTP transmission form
   (universal across communicating systems) by bracketing with the
   reserved delimiter "*".  Cryptographic state is preserved
   transparently across an excluded area and continued after the end of
   the excluded area.  A printable encoding quantum (per step 4b) is
   completed before the delimiter "*" is output to initiate or terminate
   the representation of an excluded block.  Note that the
   canonicalizing transformation (step 2 above) and the encoding to
   printable form (step 4 above) are applied to all portions of message
   text, even those excluded from encryption and authentication.

   In summary, the outbound message is subjected to the following
   composition of transformations:

     Transmit_Form = Encode(Encipher(Canonicalize(Local_Form)))

   The inverse transformations are performed, in reverse order, to
   process inbound privacy-enhanced mail:

     Local_Form = DeCanonicalize(Decipher(Decode(Transmit_Form)))

   Note that the local form and the functions to transform messages to
   and from canonical form may vary between the sender and recipient
   systems without loss of information.




Linn, Privacy Task Force                                       [Page 10]

RFC 989                                                    February 1987


        Value Encoding Value Encoding Value Encoding Value Encoding
        0     A        17    R        34    i        51    z
        1     B        18    S        35    j        52    0
        2     C        19    T        36    k        53    1
        3     D        20    U        37    l        54    2
        4     E        21    V        38    m        55    3
        5     F        22    W        39    n        56    4
        6     G        23    X        40    o        57    5
        7     H        24    Y        41    p        58    6
        8     I        25    Z        42    q        59    7
        9     J        26    a        43    r        60    8
        10    K        27    b        44    s        61    9
        11    L        28    c        45    t        62    +
        12    M        29    d        46    u        63    /
        13    N        30    e        47    v
        14    O        31    f        48    w        (pad) =
        15    P        32    g        49    x
        16    Q        33    h        50    y        (1)   *

        (1) The character "*" is used to delimit portions of an
        encoded message to which encryption/authentication
        processing has not been applied.

                         Printable Encoding Characters
                                    Table 1

4.4  Encapsulation Mechanism

   Encapsulation of privacy-enhanced messages within an enclosing layer
   of headers interpreted by the electronic mail transport system offers
   a number of advantages in comparison to a flat approach in which
   certain fields within a single header are encrypted and/or carry
   cryptographic control information.  Encapsulation provides generality
   and segregates fields with user-to-user significance from those
   transformed in transit.  As far as the MTS is concerned, information
   incorporated into cryptographic authentication or encryption
   processing will reside in a message's text portion, not its header
   portion.

   The encapsulation mechanism to be used for privacy-enhanced mail is
   derived from that described in RFC934 [8] which is, in turn, based on
   precedents in the processing of message digests in the Internet
   community.  To prepare a user message for encrypted or authenticated
   transmission, it will be transformed into the representation shown in
   Figure 1.  Note that, while encryption and/or authentication
   processing of transmitted mail may depend on information contained in
   the enclosing header (e.g., "To:"), all fields inserted in the course
   of encryption/authentication processing are placed in the
   encapsulated header.  This facilitates compatibility with mail
   handling programs which accept only text, not header fields, from
   input files or from other programs.  Further, privacy enhancement



Linn, Privacy Task Force                                       [Page 11]

RFC 989                                                    February 1987


   processing can be applied recursively.

   Sensitive data should be protected by incorporating the data within
   the encapsulated text rather than by applying measures selectively to
   fields in the enclosing header.  Examples of potentially sensitive
   header information may include fields such as "Subject:", with
   contents which are significant on an end-to-end, inter-user basis.
   The (possibly empty) set of headers to which protection is to be
   applied is a user option.  If an authenticated version of header
   information is desired, that data can be replicated within the
   encapsulated text portion in addition to its inclusion in the
   enclosing header.  If a user wishes disclosure protection for header
   fields, they must occur only in the encapsulated text and not in the
   enclosing or encapsulated header.  If disclosure protection is
   desired for the "Subject:" field, it is recommended that the
   enclosing header contain a "Subject:" field indicating that
   "Encrypted Mail Follows".

   A specific point regarding the integration of privacy-enhanced mail
   facilities with the message encapsulation mechanism is worthy of
   note.  The subset of IA5 selected for transmission encoding
   intentionally excludes the character "-", so encapsulated text can be
   distinguished unambiguously from a message's closing encapsulation
   boundary (Post-EB) without recourse to character stuffing.

4.5  Processing for Authentication Without Confidentiality

   When a message is to be authenticated without confidentiality
   service, a DEK is generated [9] for use in MAC computation, and a MAC
   is computed using that DEK.  For each individually identified
   recipient, an IK is selected and identified with an "X-IK-ID:" field.
   Each "X-IK-ID:" field is followed by an "X-Key-Info:" field which
   transfers the key under which MAC computation was performed,
   encrypted under the IK identified by the preceding "X-IK-ID:" field,
   along with a representation of the MAC encrypted under the same IK.
   The encapsulated text portion following the encapsulated header is
   canonically encoded, and coded into printable characters for
   transmission, but not encrypted.
















Linn, Privacy Task Force                                       [Page 12]

RFC 989                                                    February 1987


   Enclosing Header Portion

          (Contains header fields per RFC-822)

   Blank Line

          (Separates Enclosing Header from Encapsulated Message)

   Encapsulated Message

       Pre-Encapsulation Boundary (Pre-EB)

           -----PRIVACY-ENHANCED MESSAGE BOUNDARY-----

       Encapsulated Header Portion

           (Contains encryption control fields inserted in plaintext.
           Examples include "X-IV:", "X-IK-ID:", "X-Key-Info:",
           and "X-Pad-Count:".  Note that, although these control
           fields have line-oriented representations similar to
           RFC-822 header fields, the set of fields valid in this
           context is disjoint from those used in RFC-822 processing.)

       Blank Line

           (Separates Encapsulated Header from subsequent encoded
           Encapsulated Text Portion)

       Encapsulated Text Portion

           (Contains message data encoded as specified in Section 4.3;
           may incorporate protected copies of "Subject:", etc.)

       Post-Encapsulation Boundary (Post-EB)

           -----PRIVACY-ENHANCED MESSAGE BOUNDARY-----

                           Message Encapsulation
                                 Figure 1

4.6  Processing for Authentication and Confidentiality

   When a message is to be authenticated with confidentiality service, a
   DEK is generated for use in MAC computation and a variant of the DEK
   is formed for use in message encryption.  For each individually
   identified recipient, an IK is selected and identified with an "X-
   IK-ID:" field.  Each "X-IK-ID:" field is followed by an "X-Key-Info:"
   field, which transfers the DEK and computed MAC, each encrypted under
   the IK identified in the preceding "X-IK-ID:" field.  The
   encapsulated text portion following the encapsulated header is
   canonically encoded, encrypted, and coded into printable characters



Linn, Privacy Task Force                                       [Page 13]

RFC 989                                                    February 1987


   for transmission.

4.7  Mail for Mailing Lists

   When mail is addressed to mailing lists, two different methods of
   processing can be applicable: the IK-per-list method and the IK-per-
   recipient method.  The choice depends on the information available to
   the sender and on the sender's preference.

   If a message's sender addresses a message to a list name or alias,
   use of an IK associated with that name or alias as a entity (IK-per-
   list), rather than resolution of the name or alias to its constituent
   destinations, is implied.  Such an IK must, therefore, be available
   to all list members.  This alternative will be the normal case for
   messages sent via remote exploder sites, as a sender to such lists
   may not be cognizant of the set of individual recipients.
   Unfortunately, it implies an undesirable level of exposure for the
   shared IK, and makes its revocation difficult.  Moreover, use of the
   IK-per-list method allows any holder of the list's IK to masquerade
   as another sender to the list for authentication purposes.

   If, in contrast, a message's sender is equipped to expand the
   destination mailing list into its individual constituents and elects
   to do so (IK-per-recipient), the message's DEK and MAC will be
   encrypted under each per-recipient IK and all such encrypted
   representations will be incorporated into the transmitted message.
   (Note that per-recipient encryption is required only for the
   relatively small DEK and MAC quantities carried in the X-Key-Info
   field, not for the message text which is, in general, much larger.)
   Although more IKs are involved in processing under the IK-per-
   recipient method, the pairwise IKs can be individually revoked and
   possession of one IK does not enable a successful masquerade of
   another user on the list.

4.8  Summary of Added Header and Control Fields

   This section summarizes the syntax and semantics of the new header
   and control fields to be added to messages in the course of privacy
   enhancement processing, indicating whether a particular field occurs
   in a message's encapsulated header portion or its encapsulated text
   portion.  Figure 2 shows the appearance of a small example
   encapsulated message using these fields.  In all cases, hexadecimal
   quantities are represented as contiguous strings of digits, where
   each digit is represented by a character from the ranges "0"-"9" or
   upper case "A"-"F".  Unless otherwise specified, all arguments are to
   be processed in a case-sensitive fashion.

   Although the encapsulated header fields resemble RFC-822 header
   fields, they are a disjoint set and will not in general be processed
   by the same parser which operates on enclosing header fields.  The
   complexity of lexical analysis needed and appropriate for



Linn, Privacy Task Force                                       [Page 14]

RFC 989                                                    February 1987


   encapsulated header field processing is significantly less than that
   appropriate to RFC-822 header processing.  For example, many
   characters with special significance to RFC-822 at the syntactic
   level have no such significance within encapsulated header fields.

   The "X-IK-ID" and "X-Key-Info" fields are the only encapsulated
   header fields with lengths which can vary beyond a size conveniently
   printable on a line.  Whitespace may be used between the subfields of
   these fields to fold them in the manner of RFC-822; such whitespace
   is not to be interpreted as a part of a subfield.

      -----PRIVACY-ENHANCED MESSAGE BOUNDARY-----
      X-Proc-Type: 1,E
      X-Pad-Count: 1
      X-IV: F8143EDE5960C597
      X-IK-ID: JL:3:ECB
      X-Key-Info: 9FD3AAD2F2691B9A,B70665BB9BF7CBCD
      X-IK-ID: JL:1:ECB
      X-Key-Info: 161A3F75DC82EF26,E2EF532C65CBCFF7

      LLrHB0eJzyhP+/fSStdW8okeEnv47jxe7SJ/iN72ohNcUk2jHEUSoH1nvNSIWL9M
      8tEjmF/zxB+bATMtPjCUWbz8Lr9wloXIkjHUlBLpvXR0UrUzYbkNpk0agV2IzUpk
      J6UiRRGcDSvzrsoK+oNvqu6z7Xs5Xfz5rDqUcMlK1Z6720dcBWGGsDLpTpSCnpot
      dXd/H5LMDWnonNvPCwQUHt==
      -----PRIVACY-ENHANCED MESSAGE BOUNDARY-----

                         Example Encapsulated Message
                                   Figure 2


     X-IK-ID:      This field is placed in the encapsulated header
                   portion of a message to identify the Interchange Key
                   used for encryption of an associated Data Encrypting
                   Key or keys (used for message text encryption and/or
                   MAC computation).  This field is used for messages
                   authenticated without confidentiality service and for
                   messages authenticated with confidentiality service.
                   The field contains (in order) an Issuing Authority
                   subfield and an IK Qualifier subfield, and may also
                   contain an optional IK Use Indicator subfield.  The
                   subfields are delimited by the colon character (":"),
                   optionally followed by whitespace.  Section 5.1.2,
                   Interchange Keys, discusses the semantics of these
                   subfields and specifies the alphabet from which they
                   are chosen.  Note that multiple X-IK-ID fields may
                   occur within a single encapsulated header.  Each X-
                   IK-ID field is associated with an immediately
                   subsequent X-Key-Info field.

     X-IV:         This field is placed in the encapsulated header
                   portion of a message to carry the Initializing Vector



Linn, Privacy Task Force                                       [Page 15]

RFC 989                                                    February 1987


                   used for message encryption.  It is used only for
                   messages where confidentiality service is applied.
                   Following the field name, and one or more delimiting
                   whitespace characters, a 64-bit Initializing Vector
                   is represented as a contiguous string of 16
                   hexadecimal digits.

     X-Key-Info:   This field is placed in a message's encapsulated
                   header portion to transfer two items: a DEK and a
                   MAC.  Both items are encrypted under the IK
                   identified by a preceding X-IK-ID field; they are
                   represented as two strings of contiguous hexadecimal
                   digits, separated by a comma.  For DEA-1, the DEK
                   representation will be 16 hexadecimal digits
                   (corresponding to a 64-bit key); this subfield can be
                   extended to 32 hexadecimal digits (corresponding to a
                   128-bit key) if required to support other algorithms.
                   The MAC is a 64-bit quantity, represented as 16
                   hexadecimal digits.  The MAC is computed under an
                   unmodified version of the DEK.  Message encryption is
                   performed using a variant of the DEK, formed by
                   modulo-2 addition of the hexadecimal quantity
                   F0F0F0F0F0F0F0F0 to the DEK.

     X-Pad-Count:  This field is placed in the encapsulated header
                   portion of a message to indicate the number of zero-
                   valued octets which were added to pad the input
                   stream to the encryption function to an integral
                   multiple of eight octets, as required by the DEA-1
                   CBC encryption mode.  A decimal number in the range
                   0-7 follows the field name, and one or more
                   delimiting whitespace characters.  Inclusion of this
                   field allows disambiguation between terminal zero-
                   valued octets in message text (admittedly, a
                   relatively unlikely prospect) and zero-valued octets
                   inserted for padding purposes.

     X-Proc-Type:  This field is placed in the encapsulated header
                   portion of a message to identify the type of
                   processing performed on the transmitted message.  The
                   first subfield is a decimal version number, which
                   will be used if future developments make it necessary
                   to redefine the interpretation of encapsulated header
                   fields.  At present, this field may assume only the
                   value "1".  The second subfield, delimited by a
                   comma, assumes one of two single-character alphabetic
                   values: "A" and "E", to signify, respectively, (1)
                   authentication processing only and (2) the
                   combination of authentication and confidentiality
                   service through encryption.




Linn, Privacy Task Force                                       [Page 16]

RFC 989                                                    February 1987


5 Key Management

5.1 Types of Keys

5.1.1 Data Encrypting Keys (DEKs)

   Data Encrypting Keys (DEKs) are used for encryption of message text
   and for computation of message authentication codes (MACs).  It is
   strongly recommended that DEKs be generated and used on a one-time
   basis.  A transmitted message will incorporate a representation of
   the DEK encrypted under an interchange key (IK) known to the
   authorized recipient.

   DEK generation can be performed either centrally by key distribution
   centers (KDCs) or by endpoint systems.  One advantage of centralized
   KDC-based generation is that DEKs can be returned to endpoints
   already encrypted under the IKs of message recipients.  This reduces
   IK exposure and simplifies endpoint key management requirements.
   Further, dedicated KDC systems may be able to implement better
   algorithms for random key generation than can be supported in
   endpoint systems.  On the other hand, decentralization allows
   endpoints to be relatively self-sufficient, reducing the level of
   trust which must be placed in components other than a message's
   originator and recipient.  Moreover, decentralized DEK generation by
   endpoints reduces the frequency with which senders must make real-
   time queries of (potentially unique) servers in order to send mail,
   enhancing communications availability.

5.1.2 Interchange Keys (IKs)

   Interchange Keys (IKs) are used to encrypt Data Encrypting Keys.  In
   general, the granularity of IK usage is at the pairwise per-user
   level except for mail sent to address lists comprising multiple
   users.  In order for two principals to engage in a useful exchange of
   privacy-enhanced electronic mail using conventional cryptography,
   they must first share a common interchange key.  When asymmetric
   cryptography is used, an originator and recipient must possess
   appropriate public and secret components which, in composition,
   constitute an interchange key.

   The means by which interchange keys are provided to appropriate
   parties are outside the scope of this RFC, but may be centralized
   (e.g., via key management servers) or decentralized (e.g., via direct
   distribution among users).  In any case, a given IK is associated
   with a responsible Issuing Authority (IA).  When an IA generates and
   distributes an IK, associated control information must be provided to
   direct how that IK is to be used.  In order to select the appropriate
   IK to use in message encryption, a sender must retain a
   correspondence between IKs and the recipients with which they are
   associated.  Expiration date information must also be retained, in
   order that cached entries may be invalidated and replaced as



Linn, Privacy Task Force                                       [Page 17]

RFC 989                                                    February 1987


   appropriate.

   When a privacy-enhanced message is transmitted, an indication of the
   IK (or IKs, in the case of a message sent to multiple recipients)
   used for DEK encryption must be included.  To this end, the IK ID
   construct is defined to provide the following data:

        1.   Identification of the relevant Issuing Authority (IA
             subfield)

        2.   Qualifier string to distinguish the particular IK within
             the set of IKs distributed by the IA (IK qualifier
             subfield)

        3.   (Optional) Indicator of IK usage mode (IK use indicator
             subfield)


   The subfields of an IK ID are delimited with the colon character
   (":").  The IA and IK qualifier subfields are generated from a
   restricted character set, as prescribed by the following BNF (using
   notation as defined in RFC-822, sections 2 and 3.3):

   IAorIKQual   :=      1*ia-char

   ia-char      :=      DIGIT / ALPHA / "'" / "+" / "(" / ")" /
                        "," / "." / "/" / "=" / "?" / "-" / "@" /
                        "%" / "!" / '"' / "_" / "<" / ">"

   The IK use indicator subfield assumes a value from a small set of
   reserved strings, described later in this section.

   IA identifiers must be assigned in a manner which assures uniqueness.
   This can be done on a centralized or hierarchic basis.

   The IK qualifier string format may vary among different IAs, but must
   satisfy certain functional constraints.  An IA's IK qualifiers must
   be sufficient to distinguish among the set of IKs issued by that IA.
   Since a message may be sent with multiple IK IDs, corresponding to
   multiple intended recipients, each recipient must be able to
   determine which IK is intended for it.  Moreover, if no corresponding
   IK is available in the recipient's database when a message arrives,
   the recipient must be able to determine which IK to request and to
   identify that IK's associated IA.  Note that different IKs may be
   used for different messages between a pair of communicants.
   Consider, for example, one message sent from A to B and another
   message sent (using the IK-per-list method) from A to a mailing list
   of which B is a member.  The first message would use an IK shared
   between A and B, but the second would use an IK shared among list
   members.




Linn, Privacy Task Force                                       [Page 18]

RFC 989                                                    February 1987


   While use of a monotonically increasing number as an IK qualifier is
   sufficient to distinguish among the set of IKs distributed by an IA,
   it offers no facility for a recipient lacking a matching IK to
   determine the appropriate IK to request.  This suggests that sender
   and recipient name information should be incorporated into an IK
   qualifier, along with a number to distinguish among multiple IKs used
   between a sender/recipient pair.  In order to support universal
   interoperability, it is necessary to assume a universal form for the
   naming information.  General definition of such a form requires
   further study; issues and possible approaches will be noted in
   Section 6.  As an interim measure, the following IK qualifier format
   is suggested:

              <sender-name>/<recipient-name>/<numid>

   where <sender-name> and <recipient-name> are in the following form:

              <user>@<domain-qualified-host>

   For the case of installations which transform local host names before
   transmission into the broader Internet, it is strongly recommended
   that the host name as presented to the Internet be employed.  The
   <numid> is a contiguous string of decimal digits.

   The IK use indicator subfield is an optional facility, provided to
   identify the encryption mode in which the IK is to be used.
   Currently, this subfield may assume the following reserved string
   values: "ECB" and "EDE"; the default value is ECB.

   An example IK ID adhering to this recommendation is as follows:

          ptf-kmc:linn@CCY.BBN.COM/privacy-tf@C.ISI.EDU/2:ECB

   This IK ID would indicate that IA "ptf-kmc" has issued an IK for use
   on messages sent from "linn@CCY.BBN.COM" to "privacy-tf@C.ISI.EDU",
   that the IA has associated number 2 with that IK, and that the IK is
   to be used in ECB mode.

   IKs will remain valid for a period which will be longer than a single
   message and will be identified by an expiration time distributed
   along with the IK; IK cryptoperiod is dictated in part by a tradeoff
   between key management overhead and revocation responsiveness.  It
   would be undesirable to delete an IK permanently before receipt of a
   message encrypted using that IK, as this would render the message
   permanently undecipherable.  Access to an expired IK would be needed,
   for example, to process mail received by a user (or system) which had
   been inactive for an extended period of time.  In order to enable
   very old IKs to be deleted, a message's recipient desiring encrypted
   local long term storage should transform the DEK used for message
   text encryption via re-encryption under a locally maintained IK,
   rather than relying on IA maintenance of old IKs for indefinite



Linn, Privacy Task Force                                       [Page 19]

RFC 989                                                    February 1987


   periods.

6 User Naming

   Unique naming of electronic mail users, as is needed in order to
   select corresponding keys correctly, is an important topic and one
   requiring significant study.  A logical association exists between
   key distribution and name/directory server functions; their
   relationship is a topic deserving further consideration.  These
   issues have not been fully resolved at this writing.  The interim
   architecture relies on association of IKs with user names represented
   in a universal form, which has the following properties:

          1.   The universal form must be specifiable by an IA as it
               distributes IKs and known to a UA as it processes
               received IKs and IK IDs.  If a UA or IA uses addresses in
               a local form which is different from the universal form,
               it must be able to perform an unambiguous mapping from
               the universal form into the local representation.

          2.   The universal form, when processed by a sender UA, must
               have a recognizable correspondence with the form of a
               recipient address as specified by a user (perhaps
               following local transformation from an alias into a
               universal form)

   It is difficult to ensure these properties throughout the Internet.
   For example, an MTS which transforms address representations between
   the local form used within an organization and the global form used
   for Internet mail transmission may cause property 2 to be violated.

   The use of flat (non-hierarchic) electronic mail user identifiers,
   which are unrelated to the hosts on which the users reside, appears
   useful.  Personal characteristics, like social security numbers,
   might be considered.  Individually-selected identifiers could be
   registered with a central authority, but a means to resolve name
   conflicts would be necessary.

   A point of particular note is the desire to accommodate multiple
   names for a single individual, in order to represent and allow
   delegation of various roles in which that individual may act.  A
   naming mechanism that binds user roles to keys is needed.  Bindings
   cannot be immutable since roles sometimes change (e.g., the
   comptroller of a corporation is fired).

   It may be appropriate to examine the prospect of extending the Domain
   Name System and its associated name servers to resolve user names to
   unique user IDs.  An additional issue arises with regard to mailing
   list support: name servers do not currently perform (potentially
   recursive) expansion of lists into users.  ISO and CSNet are working
   on user-level directory service mechanisms, which may also bear



Linn, Privacy Task Force                                       [Page 20]

RFC 989                                                    February 1987


   consideration.

7  Example User Interface and Implementation

   In order to place the mechanisms and approaches discussed in this RFC
   into context, this section presents an overview of a prototype
   implementation.  This implementation is a standalone program [10]
   which is invoked by a user, and lies above the existing UA sublayer.
   This form of integration offers the advantage that the program can be
   used in conjunction with a range of UA programs, rather than being
   compatible only with a particular UA.  When a user wishes to apply
   privacy enhancements to an outgoing message, the user prepares the
   message's text and invokes the standalone program (interacting with
   the program in order to provide address information and other data
   required to perform privacy enhancement processing), which in turn
   generates output suitable for transmission via the UA.  When a user
   receives a privacy-enhanced message, the UA delivers the message in
   encrypted form, suitable for decryption and associated processing by
   the standalone program.

   In this prototype implementation, a cache of IKs is maintained in a
   local file, with entries managed manually based on pairwise
   agreements between originators and recipients.  This cache is,
   effectively, a simple database.  IKs are selected for transmitted
   messages based on recipient names, and corresponding IK IDs are
   placed into the message's encapsulated header.  When a message is
   received, the IK ID is used as a basis for a lookup in the database,
   yielding the appropriate IK entry.  DEKs and IVs are generated
   dynamically within the program.

   Options (e.g., authentication only vs. authentication with
   confidentiality service) are selected by command line arguments to
   the standalone program.  Destination addresses are specified in the
   same fashion.  The function of specifying destination addresses to
   the privacy enhancement program is logically distinct from the
   function of specifying the corresponding addresses to the UA for use
   by the MTS.  This separation results from the fact that, in many
   cases, the local form of an address as specified to a UA differs from
   the Internet global form as used for IK ID fields.

8  Areas For Further Study

   The procedures defined in this RFC are sufficient to support pilot
   implementation of privacy-enhanced electronic mail transmission among
   cooperating parties in the Internet.  Further effort will be needed,
   however, to enhance robustness, generality, and interoperability.  In
   particular, further work is needed in the following areas:


     1.   User naming techniques, and their relationship to the domain
          system, name servers, directory services, and key management



Linn, Privacy Task Force                                       [Page 21]

RFC 989                                                    February 1987


          functions

     2.   Standardization of Issuing Authority functions, including
          protocols for communications among IAs and between User Agents
          and IAs

     3.   Use of public key encryption algorithms to encrypt data
          encrypting keys

     4.   Interoperability with X.400 mail

   We anticipate generation of subsequent RFCs which will address these
   topics.


9 References

   This section identifies background references which may be useful to
   those contemplating use of the mechanisms defined in this RFC.


     ISO 7498/Part 2 - Security Architecture, prepared by ISO.TC97/SC
          21/WG 1 Ad hoc group on Security, extends the OSI Basic
          Reference Model to cover security aspects which are general
          architectural elements of communications protocols, and
          provides an annex with tutorial and background information.

     US Federal Information Processing Standards Publication (FIPS PUB)
          46, Data Encryption Standard, 15 January 1977, defines the
          encipherment algorithm used for message text encryption and
          MAC computation.

     FIPS PUB 81, DES Modes of Operation, 2 December 1980, defines
          specific modes in which the Data Encryption Standard algorithm
          is to be used to perform encryption and MAC computation.

NOTES:


     [1]  Information Processing Systems: Data Encipherment: Block
          Cipher Algorithm DEA 1.

     [2]  Federal Information Processing Standards Publication 46, Data
          Encryption Standard, 15 January 1977.

     [3]  Information Processing Systems: Data Encipherment: Modes of
          Operation of a 64-bit Block Cipher

     [4]  Federal Information Processing Standards Publication 81, DES
          Modes of Operation, 2 December 1980.




Linn, Privacy Task Force                                       [Page 22]

RFC 989                                                    February 1987


     [5]  Addendum to the Transport Layer Protocol Definition for
          Providing Connection Oriented End to End Cryptographic Data
          Protection Using a 64-Bit Block Cipher, X3T1-85-50.3, draft of
          19 December 1985, Gaithersburg, MD, p. 15.

     [6]  This transformation should occur only at an SMTP endpoint, not
          at an intervening relay, but may take place at a gateway
          system linking the SMTP realm with other environments.

     [7]  Crocker, D. Standard for the Format of ARPA Internet Text
          Messages (RFC822), August 1982.

     [8]  Rose, M. T., and Stefferud, E. A., Proposed Standard for
          Message Encapsulation, January 1985.

     [9]  Key generation for authentication and message text encryption
          may either be performed by the sending host or by a
          centralized server.  This RFC does not constrain this design
          alternative.  Section 5.1.1 identifies possible advantages of
          a centralized server approach.

     [10] Note that in the UNIX(tm) system, and possibly in other
          environments as well, such a program can be invoked as a
          "filter" within an electronic mail UA or a text editor,
          simplifying the sequence of operations which must be performed
          by the user.




























Linn, Privacy Task Force                                       [Page 23]

-- 
Copyright 1987 John Gilmore; you can redistribute only if your recipients can.
(This is an effort to bend Stargate to work with Usenet, not against it.)
{sun,ptsfa,lll-crg,ihnp4,ucbvax}!hoptoad!gnu	       gnu@ingres.berkeley.edu
DES info wanted
#3558
Author: Pat "Hack #2" Kenny
Date: Wed, 06 May 1987 18:42
20 lines
1593 bytes
I have written a DES program in pascal for a term project and I have
to do a talk about it soon and I would like to ask some questions for
anybody to respond to, thanks in advance.

1. How much is DES used and who uses it?
2. Does anybody really know what the numbers in the S-Boxes are and where
   they got them.
3. Where is the DES implemented? I heard about it being put into those
   instant cash machines, is that true?
4. Does anybody know about the DES and unix, I know they use it there, but
   how much did they change it?
5. What does the NSA know about the DES that we don't? Do they have a machine
   to crack it?
6. Are there any DES jokes or other names for DES?

   Thanks, any help would be helpful. 
--------------------------------------------------------------------------
Pat Kenny on the edge of infinity (DULUTH MN).
			Come and see what it looks like.
---------------------------------------------------------------------------
Re: DES info wanted
#3559
Author: Simson L. Garfinkel
Date: Wed, 06 May 1987 21:01
17 lines
1288 bytes
In article <599@umnd-cs.D.UMN.EDU> pkenny1@ub.UUCP (Pat "Hack #2" Kenny) writes:
>2. Does anybody really know what the numbers in the S-Boxes are and where
>   they got them.

This is classified.

>4. Does anybody know about the DES and unix, I know they use it there, but
>   how much did they change it?

A varient of DES is used in cypt(3) call (used for password
encrypting). It uses different s-boxes so that you can't use a DES chip
to break unix passwords. (Instead, you have to use Bob Baldwin's program.)

>5. What does the NSA know about the DES that we don't? Do they have a machine
>   to crack it?

This is also classified.
Re: DES info wanted
#3560
Author: Scott Rotondo
Date: Wed, 06 May 1987 21:01
52 lines
3111 bytes
In article <599@umnd-cs.D.UMN.EDU> pkenny1@ub.UUCP (Pat "Hack #2" Kenny) writes:

> 1. How much is DES used and who uses it?

DES is widely used for commercial and government (non-military) encryption.
It is due to be recertified in a year or two, and chances are it will not
be considered to be secure enough.  The new scheme the NSA is pushing
puts them in the role of key distributor, and it keeps the algorithm
secret.  Not the way to do a realistic encryption system.  At any rate,
assuming it is not recertified, current levels of usage should decline
(except electronic banking, see below).

> 2. Does anybody really know what the numbers in the S-Boxes are and where
>    they got them.

Everyone knows what the numbers in the S-boxes are (you had to know to write
your program), but how they arrived at those numbers is still classified.

> 3. Where is the DES implemented? I heard about it being put into those
>    instant cash machines, is that true?

DES is the standard system used in electronic funds transfers, including 
automated tellers.  This is the one area where the NSA proposes that the
government continue to use DES, as the Treasury Dept. does a lot of
funds transfers.

> 4. Does anybody know about the DES and unix, I know they use it there, but
>    how much did they change it?

DES is used in the Unix crypt(3) function (NOT crypt(1)) to encode passwords.
The algorithm is DES except that the initial permutation is altered to one
of 4096 possibilities by the first two characters in the passwd file entry,
known as "salt" bits.  This makes it impossible to encrypt common words
and then check them against all the passwd entries looking for a match.

> 5. What does the NSA know about the DES that we don't? Do they have a machine
>    to crack it?

The main thing that NSA knows is the way in which the S-box numbers were
derived.  There has been speculation without proof that there is a trap
door here to allow the NSA to crack it.  There has also been speculation
that the NSA cannot crack DES, and that is why they are pushing for a new
standard where they control the keys and the algorithm.

> 6. Are there any DES jokes or other names for DES?

The only other name I can think of is Digital Encryption Standard, which 
some people think DES stands for instead of Data Encryption Standard.

			Hope this is helpful.

			-- Scott
Re: DES info wanted
#3561
Author: Doug Gwyn
Date: Thu, 07 May 1987 06:15
51 lines
3720 bytes
In article <18742@ucbvax.BERKELEY.EDU> rotondo@ernie.Berkeley.EDU.UUCP (Scott Rotondo) writes:
>The main thing that NSA knows is the way in which the S-box numbers were
>derived.  There has been speculation without proof that there is a trap
>door here to allow the NSA to crack it.  There has also been speculation
>that the NSA cannot crack DES, and that is why they are pushing for a new
>standard where they control the keys and the algorithm.

Although I haven't studied DES very hard and don't have any inside
(i.e. classified) information about DES, from a previous life as a
part-time cryppy I don't see how DES could be considered unbreakable,
in the absence of sufficiently frequent key changes.  This follows
from very general information-theoretical considerations.  Because of
the complexity of the encryption algorithm, the unicity distance is
probably rather large, but it wouldn't be infinite.  On the other
hand, it is probable that it would take knowledge that only NSA and
similar organizations tend to have to routinely break DES using
economically feasible expenditure of resources.  Since I have to be
careful not to discuss anything about this subject for which I can't
point to publicly-available descriptions, suffice it to say that the
articles I've seen on cryptography in the open literature don't hold
a candle to the ones I used to read in the NSA Technical Journal.  I
would bet that NSA can break DES any time they so choose, if they
have a large enough contiguous sample of the cipher stream; "trap
doors" shouldn't be necessary.

The newer proposal for general government encryption amounts to a
reversion to the military way of doing business; they have always
classified both the keys and encryption system details
(algorithms).  Even though it's taken for granted in the cryppy
business that the "opposition" sooner or later determines the
details of the encryption system, it still makes sense to try to
delay their doing so.  The keys of course must be protected.
(So-called "public key" systems attempt to make the latter
unnecessary, but I wouldn't place reliance on the opposition's
lack of sufficient cleverness or dumb luck to protect anything of
very great value.)

Consider this:  If NSA can really design a truly secure system
for government use, then they sure as hell wouldn't want everyone
whose traffic they read to learn how to do the same.  It is
perfectly natural that no details of how critical aspects of a
secure cryptosystem are determined are made public.  (Personally
I would love for there to be a universally-used secure system,
since I value privacy.  But virtually no government operates on
such abstract considerations; rather they attempt to attain
short-range advantage over other governments as expeditiously as
possible.  I wish ours were different, and think it once was.)

In summary, I don't think there is a conspiracy on NSA's part,
and I estimate NSA's capabilities to be higher than other people
seem to think.  (I suspect NSA is happy to be underestimated.)
Re: DES info wanted
#3562
Author: rotondo
Date: Thu, 07 May 1987 18:17
48 lines
3201 bytes
In article <5841@brl-smoke.ARPA> gwyn@brl.arpa (Doug Gwyn) writes:

> Although I haven't studied DES very hard and don't have any inside
> (i.e. classified) information about DES, from a previous life as a
> part-time cryppy I don't see how DES could be considered unbreakable,
> in the absence of sufficiently frequent key changes.  This follows
> from very general information-theoretical considerations.  Because of
> the complexity of the encryption algorithm, the unicity distance is
> probably rather large, but it wouldn't be infinite.  
[ ... ]
> I would bet that NSA can break DES any time they so choose, if they
> have a large enough contiguous sample of the cipher stream; "trap
> doors" shouldn't be necessary.

Let me start with the disclaimer that I have access only to the open
literature on the subject, so your information may be more reliable
than mine.  

My understanding of the information theoretic argument is that the
unicity distance indicates the approximate amount of ciphertext
needed to break the cipher using infinite computational resources.
As is the case with all systems except one-time pads, the unicity
distance for DES is quite finite (about 18 chars).  However, actually
doing the computation seems to require an exhaustive search of 2^55
keys (not 2^56 because of a known symmetry in the S-boxes).  The
only apparent way to reduce this search is to know about a trap door
in the S-boxes (or elsewhere, but I don't see where).

I probably should have pointed out in my previous posting that a
perfectly valid reason for the NSA to be pushing for a new 
standard is that the old one just isn't secure enough.  A search
of 2^55 keys isn't as prohibitive as it once was [see several papers
by Martin Hellman].  Still, if I had to choose, I'd prefer that
we use DES with longer keys or multiple encryption rather than
trusting the NSA to hold the keys.  This is probably their main
reason for wanting the new system, but being able to read everyone's
mail is a nice fringe benefit.

> (So-called "public key" systems attempt to make [protecting keys]
> unnecessary, but I wouldn't place reliance on the opposition's
> lack of sufficient cleverness or dumb luck to protect anything of
> very great value.)

Does "sufficient cleverness or dumb luck" mean finding a way to factor
large numbers or something else?  My main objection to public key
systems is that they are just too slow.

				-- Scott
Re: DES info wanted
#3565
Author: Robert W. Baldwin
Date: Thu, 07 May 1987 21:53
85 lines
5314 bytes
> From: pkenny1@ub.D.UMN.EDU (Pat "Hack #2" Kenny)
>1. How much is DES used and who uses it?
>3. Where is the DES implemented? I heard about it being put into those
>   instant cash machines, is that true?

	ATM machines use DES to validate the users Personal
Identification Number (password).  Your card has a number on it which
is the result of applying a DES based function to your PIN and your
account number.  When you type in your PIN, the ATM performs this
function and lets you continue if the result matches the number on the
card.  The DES function uses a secret key that is coded in the ATM's
DES circuits.  If you know this master key you can manufacture fake
ATM cards.  If you find/make an ATM that cannot speak to the bank to
verify account numbers, then you can withdraw money using the fake
card.  The situation is more complicated for inter-bank transactions
that require remote verification of the PIN.
	The link between the bank and the ATM is not encrypted.  The
machines could be designed in such a way that this is not a security
hole, but I have heard that this is not the case.  In order to make it
easier for the banks to change the behavior of ATMs, they included
features that make it possible to spoof the machine into despensing
money provided the ATM has been given a valid card and somehow ended
up in an error state (e.g., cash was not removed from the cash
drawer).

>2. Does anybody really know what the numbers in the S-Boxes are and where
>   they got them.

	Adi Shamir noticed an interesting pattern in the s-boxes, but
he has not come up with a way to exploit the pattern.  In fact, the
pattern may be a strength.  Basically, the parity of the output of
each s-box (the xor of all four bits) is almost completely controlled
by one of the input bits.  That is, if you tell me the value of just
one of the input bits, I can predict the parity of the output bits,
and I will almost always be right.  There are values for the other 5
input bits that will make me wrong, but I will be right for most of
the 32 possible values of the 5 other input bits.

>4. Does anybody know about the DES and unix, I know they use it there, but
>   how much did they change it?

	The Unix file encryption program uses a weak variant of the
Enigma cipher system which the Germans used during WWII.  The October
1984 issue (v63 n8) of the ATT Bell Labs Technical Journal (pg
1673-1683) has an article by Jim Reeds and Peter Weinberger on
breaking this cipher system.  I wrote an interactive workbench, CBW,
for break the cipher and it is about to be distributed on
mod.sources.  If you must use the Unix file encryptor, run your file
through compress or compact first.
	The Unix password hashing function is based on DES.
Basically, your password is used as the key to encrypt the constant
zero 25 times.  The result is compared against a number in
/etc/passwd, and if they match, you are let in.  More precisely, there
are 4096 variants of DES and the specific one that is used is
specified by two 'salting' characters that are in your line of the
password file.  Thus, the login program asks for your username, looks you
up in the password file to find out which variant to use, and then ask
for your password.  The password and the two salting characters are
passed to a function called crypt (not to be confused with the file
encryption program with the same name) that performs the 25 iterations
of the salted DES and returns a result that can be compared with the
'encrypted' ('hashed' would be a better term) password in your line
of /etc/passwd.
	The salting effects the expansion function, E, not the
S-Boxes, as simson@amt said, nor the initial permutation, IP, as
rotondo@ernie said.  The strength of DES depends on the details of the
S-boxes so fooling with those is a bad idea.  Changing the IP would
still allow an attacker to use DES chips to crack password files.
	A high speed implementation of the salted des transform is
available on eddie.mit.edu (ihnp4!mit-eddie) in
/usr/spool/uucppublic/fdes.tar.  This includes documentation that
explains the tricks used to get the factor of 40 increase in speed.
Most of the tricks have been published by Marc Davio, Yvo Desmedt, et
al. in the proceedings of EuroCrypt 1983.  The new trick is a
five instruction implementation of the salting.

>6. Are there any DES jokes or other names for DES?
	Does Everyone Spy?
	Do Encryption Spell (stuff) (shit) (slowly)
	Decryption Extra Simple (slow) (speedy)


		--Bob Baldwin
		baldwin@xx.lcs.mit.edu
		ihnp4!mit-eddie!baldwin.UUCP
Re: DES info wanted
#3566
Author: D 1 4 U 2 C
Date: Fri, 08 May 1987 00:13
14 lines
1184 bytes
In a very informative article Robert W. Baldwin writes one thing
I just can't believe:
) 
) Your card has a number on it which
) is the result of applying a DES based function to your PIN and your
) account number.  When you type in your PIN, the ATM performs this
) function and lets you continue if the result matches the number on the
) card.

But two of my cards (AmEx and Discover) came with forms for changing
my PIN.  All I had to do was send in the form and wait two weeks
before using the new PIN.  This argues for remote verification.

			Matt Crawford
Re: DES info wanted
#3571
Author: Ken Yap
Date: Fri, 08 May 1987 02:14
12 lines
1137 bytes
This is only vaguely related to DES so maybe I should have changed the
subject line.

A friend of mine discovered something interesting about the way some
(all?) ATM's work. He put in a non-participating bank's card and the
machine cycled him through the whole validation sequence before
spitting out the card with the message "invalid card" or something like
that. So it looks like the ATM makes up a whole package of info before
firing it off to the mainframe. I can just imagine the Cobol code,
yuk!

	Ken
Re: DES info wanted
#3563
Author: gwyn
Date: Fri, 08 May 1987 07:17
58 lines
4188 bytes
In article <18771@ucbvax.BERKELEY.EDU> rotondo@ernie.Berkeley.EDU.UUCP (Scott Rotondo) writes:
>...  However, actually
>doing the computation seems to require an exhaustive search of 2^55
>keys (not 2^56 because of a known symmetry in the S-boxes).

Let me assure you that cryptanalysts virtually never search a space
anywhere near that large.  Rather, they exploit algebraic structure
of the encipherment system, using a variety of techniques.  One
rather puny, although publicly-known, example goes by the name
"indirect symmetry of position"; it's described in Kahn (unabridged).
I once implemented this on a computer and watched messages "unravel".
For more modern systems including DES, one would use much more
sophisticated algebraic methods than that, but until I find public
references I can't disclose even the limited amount I know about this.

I don't want to give the impression that cryptanalysis involves
merely solving exact equations, however.  A barrage of statistical
tests are in general performed to steer the analysis into the most
productive directions; you can think of this as favoring certain
branches of the search tree of possibilities.  One of the best
public introductions to this area that I know of is the quite old
technical paper (more like a book) by Solomon Kullback entitled
"Statistical Methods in Cryptanalysis".  It was published by the
War Department in 1938 (revised edition) and was originally
Confidential, later Restricted, now declassified via automatic
downgrading rules.  I don't know a source for this, but Aegean
Press might be one.  (I'm getting their book list soon; they have
at least some older editions of Mil Cryp for sale.)  Certainly
there has been a lot of progress in this area since then..

>Does "sufficient cleverness or dumb luck" mean finding a way to factor
>large numbers or something else?

"Sufficient cleverness" was mostly an oblique reference to the widely-
held idea that one would have to factor the product of two large
primes to crack a public-key system.  Some people have maintained that
any algorithm for cracking such a system amounts to an algorithm for
the factorization, but I haven't been convinced that this conclusion
is warranted.  "Dumb luck" means any of a variety of ways a system
could be cracked besides exploiting a clever analytic algorithm.
Practical cryptanalysis of difficult systems often involves looking
for easy wedges into the messages; examples from older systems
include finding isomorphs (same message encrypted twice under
different keys, sometimes different systems), crib dragging (guessing
at the presence of probably plaintext phrases and trying to lever
open the key under the assumption that the phrase occurs at a
particular location), looking for hardware malfunctions (stuck shift
registers, for example), and so forth.  These methods, while tedious
(unless computers are used), are far, far less work than any brute
force approach such as trying all possible keys.  Sometimes they pay
off and sometimes they don't; when luck is with the analyst,
nominally-secure traffic can be read.

As you can undoubtedly tell, I find the amount of ingenuity that can
be applied to cryptanalysis quite fascinating.  I think this would be
a wondeful subject for a college curriculum, although the number of
potential employers for cryppies isn't very large yet.  (It's growing
as attention focuses on commercial data transmission.)
Re: DES info wanted
#3568
Author: Simson L. Garfinkel
Date: Fri, 08 May 1987 14:28
9 lines
1199 bytes
I believe that there are currently several distinct systems used for
verification of PINs. Some of them involve remote verification. Some of them
involve storing encrypted PINs on the cards. Some of them involve storing
non-encrypted PINs on the cards (indeed, most of the early systems come
under this last catagory.)

For obvious reasons, companies who issue these things are very reluctant to
dispence corect information. I've asked people at my bank on several occasions
and received several different answers.
Re: DES info wanted
#3575
Author: Robert Cray
Date: Sat, 09 May 1987 01:34
18 lines
1709 bytes
In article <18742@ucbvax.BERKELEY.EDU> rotondo@ernie.Berkeley.EDU.UUCP (Scott Rotondo) writes:
>DES is used in the Unix crypt(3) function (NOT crypt(1)) to encode passwords.
>The algorithm is DES except that the initial permutation is altered to one
>of 4096 possibilities by the first two characters in the passwd file entry,
>known as "salt" bits.  This makes it impossible to encrypt common words
>and then check them against all the passwd entries looking for a match.
>

You are correct, however I would add that there exist implimentations of
crypt(3) that are fairly fast (Bob Baldwin's fdes) -- when I tried it, it
could run through about 50,000 calls to fcrypt(3) (on an 11/780) in
about 45 minutes. Given a few days, someone with bad intentions could
easily check a list of "common" words against every user (each word
would have to be re-encrypted for every user).  The same is true for the
password-encryption on VMS, except that the VMS routines (that were posted
to the net) go through about 50k words in ~11 minutes.

					--robert
Re: DES info wanted
#3576
Author: Jeff Siegal
Date: Sun, 10 May 1987 00:28
25 lines
1891 bytes
In article <566@jimi.cs.unlv.edu> robert@jimi.UUCP (Robert Cray) writes:
>In article <18742@ucbvax.BERKELEY.EDU> rotondo@ernie.Berkeley.EDU.UUCP (Scott Rotondo) writes:
>>[...] "salt" bits.  This makes it impossible to encrypt common words
>>and then check them against all the passwd entries looking for a match.

>[...] (Bob Baldwin's fdes) -- when I tried it, it
>could run through about 50,000 calls to fcrypt(3) (on an 11/780) in
>about 45 minutes. [...] check a list of "common" words against 
>every user (each word would have to be re-encrypted for every user)

Actually, if you make a hobby of cracking password files, you can
collect a library of encrypted dictionaries (i.e. each time you
encrypt the dictionary for a user using that pair of salt characters,
you keep it around on disk).  As your library grows, a substantial
portion of the users in a password file you are attempting to crack
involve a simple lookup (i.e. much < 1 sec)

>The same is true for the
>password-encryption on VMS, except that the VMS routines (that were posted
>to the net) go through about 50k words in ~11 minutes.

Except that the encrypted passwords are not available to any user on a
VMS system--you need privs to access them.

Jeff
Re: DES info wanted
#3577
Author: Marc Kaplan
Date: Sun, 10 May 1987 15:00
34 lines
2334 bytes
In article <27595@rochester.ARPA>, ken@rochester.ARPA (Ken Yap) writes:
> This is only vaguely related to DES so maybe I should have changed the
> subject line.
> 
> A friend of mine discovered something interesting about the way some
> (all?) ATM's work. He put in a non-participating bank's card and the
> machine cycled him through the whole validation sequence before
> spitting out the card with the message "invalid card" or something like
> that. So it looks like the ATM makes up a whole package of info before
> firing it off to the mainframe. I can just imagine the Cobol code,
> yuk!
> 
> 	Ken

	Well, I noticed the same situation when using my card with an
invalid PIN.  However, I reached a very different conclusion.  This is
(I assume) a security feature designed to make it harder for a "bad guy"
to guess someone's PIN.  Since it's only four digits, an average of 5000
attempts should give him the valid PIN.  If the machine tells him immediately
if his PIN is valid or invalid, it makes it *much* easier to sit there and
try numbers.  If he has to go through an entire transaction first, it
will take four or five times as long to try each number.  Unix uses a
similar strategy to discourage password guessing.  The password checking
program is slowed down by a large factor (25?) so the bad guy won't know
the results too quickly.  Unfortunately, the strategy works badly for
passwords, since too many users use first names, two character passwords,
etc.  

	BTW, I assume that the ATMs will temporarily invalidate a card if
a few hundred bad attempts are made to remove money.  At least, thats how
I would do it.

					Eric Safern
					...aecom!mkaplan
Re: DES info wanted
#3580
Author: Calvin Sambrook
Date: Mon, 11 May 1987 13:37
37 lines
2344 bytes
In article <1072@mit-amt.MEDIA.MIT.EDU> simsong@media-lab.MEDIA.MIT.EDU (Simson L. Garfinkel) writes:
>I believe that there are currently several distinct systems used for
>verification of PINs. Some of them involve remote verification. Some of them
>involve storing encrypted PINs on the cards. Some of them involve storing
>non-encrypted PINs on the cards (indeed, most of the early systems come
>under this last catagory.)
>
>For obvious reasons, companies who issue these things are very reluctant to
>dispence corect information. I've asked people at my bank on several occasions
>and received several different answers.


In 1984 some friends of mine built a card reader as part of thier lab work
for thier BSc in computer systems.  They used only commercially available
components and freely available information.

Imagine my horror (along with others in our lab group) when they demonstrated
thier ability to read our account and PIN numbers directly off our cards !

The reader (which they disassembled after their work had been assessed) cost
them just under 150 pounds (sterling) to build and was powered from 12V d.c.
I would imagine that any enterprising card thief could make a device like this
pay for itself in just a few hours.

I certainly learned a lesson from this and as well as keeping my plastic
very safe now I also check my bank statements *very* carefully !

It makes me wonder just how much money the banks lose each day...


--
calvin
-- 
--
| Wie Tabaluga sagt:     (Tabaluga und das leuchtende Schweigen - Peter Maffay)
|	Sag mal, kannst du deine Flammen nicht auspusten?
|	Mein Vater sagt auch immer: 'Bein reden spuckt man kein Feuer'
Re: DES info wanted
#3578
Author: akt
Date: Mon, 11 May 1987 16:53
10 lines
1162 bytes
In article <1072@mit-amt.MEDIA.MIT.EDU>, simsong@mit-amt.MEDIA.MIT.EDU (Simson L. Garfinkel) writes:
> [.....]
> For obvious reasons, companies who issue these things are very reluctant to
> dispence corect information. I've asked people at my bank on several occasions
> and received several different answers.

even if the banks don't tell you, ANSI will.  i have forgotten
the relevant standard numbers, but ANSI has a whole slew of them
for EFT.  they use DES extensively.  key-management is by RSA,
i think.
ATM security (was Re: DES info wanted)
#3585
Author: andersa
Date: Tue, 12 May 1987 17:18
12 lines
1262 bytes
In article <1060@aecom.YU.EDU> mkaplan@aecom.YU.EDU (Marc Kaplan) writes:
>	BTW, I assume that the ATMs will temporarily invalidate a card if
>a few hundred bad attempts are made to remove money.  At least, thats how
>I would do it.

If you make three (or maybe four) failing attempts in a row with the same
card at a Swedish ATM, the machine will swallow the card and physically
deface it (>burp!<), and you'll have to contact your bank to get a new one.
-- 
Anders Andersson, Dept. of Computer Systems, Uppsala University, Sweden
Phone: +46 18 183170
UUCP: andersa@kuling.UUCP (...!{seismo,mcvax}!enea!kuling!andersa)
Re: ATM security (was Re: DES info wanted)
#3594
Author: Marc Kaplan
Date: Mon, 18 May 1987 00:40
19 lines
1571 bytes
In article <294@kuling.UUCP>, andersa@kuling.UUCP (Anders Andersson) writes:
> In article <1060@aecom.YU.EDU> mkaplan@aecom.YU.EDU (Marc Kaplan) writes:
> >	BTW, I assume that the ATMs will temporarily invalidate a card if
> >a few hundred bad attempts are made to remove money.  At least, thats how
> >I would do it.
> 
> If you make three (or maybe four) failing attempts in a row with the same
> card at a Swedish ATM, the machine will swallow the card and physically
> deface it (>burp!<), and you'll have to contact your bank to get a new one.

	While I admit a few hundred is too much, three or four is too little.
Last week I made two mistakes before getting it right.  With this method, if
I came back the next morning and made *one* mistake, my card is history.  For
a 'bad guy', on the other hand, four attempts are not likely to net him the
number.  Four thousand is more like it.


						...aecom!mkaplan
						Eric Safern
Re: ATM security (was Re: DES info wanted)
#3598
Author: howellg
Date: Wed, 20 May 1987 09:50
15 lines
1446 bytes
In article <1071@aecom.YU.EDU> mkaplan@aecom.YU.EDU (Marc Kaplan) writes:
>In article <294@kuling.UUCP>, andersa@kuling.UUCP (Anders Andersson) writes:
>> In article <1060@aecom.YU.EDU> mkaplan@aecom.YU.EDU (Marc Kaplan) writes:
>> >	BTW, I assume that the ATMs will temporarily invalidate a card if
>> 
>> If you make three (or maybe four) failing attempts in a row with the same
>
>	While I admit a few hundred is too much, three or four is too little.

In the UK it needs 3 successive bad attempts for the card to be
invalidated.  If you make 2 then get it right on the third you are OK.
Usually the ATM card is also a cheque guarantee card so you do get the
card back but the MS is erased and the card can only be used to
guarantee cheques.
Gareth.
Re: ATM security
#3606
Author: Anders Andersson
Date: Thu, 21 May 1987 23:16
37 lines
2852 bytes
In article <1071@aecom.YU.EDU> mkaplan@aecom.YU.EDU (Marc Kaplan) writes:
>In article <294@kuling.UUCP>, andersa@kuling.UUCP (Anders Andersson) writes:
>> If you make three (or maybe four) failing attempts in a row with the same
>> card at a Swedish ATM, the machine will swallow the card and physically
>> deface it (>burp!<), and you'll have to contact your bank to get a new one.
>
>	While I admit a few hundred is too much, three or four is too little.
>Last week I made two mistakes before getting it right.  With this method, if
>I came back the next morning and made *one* mistake, my card is history.  For
>a 'bad guy', on the other hand, four attempts are not likely to net him the
>number.  Four thousand is more like it.

Note, in a *row*. I believe all attempts has to be done during the same
session at the ATM, and even if it kept the counter "alive" for your
particular card over the night (which I don't think it does), your single
intermediary successful attempt should be enough to reset it. If I were to
make two failing attempts in a row I would probably step aside and let next
customer do his business while my counter was reset, just to make sure, or
I could take a walk to another ATM (it could be that the first just had a
bad keypad). If that one goofed my card at first try, I would probably
complain at the bank about stupid and user-hostile algorithms.

The above scheme will at least cause some considerable delay for the
impostor trying to find the code either randomly or systematically.
He would have to step back, waiting for the ATM session to timeout,
every two or three attempts. Trying 4,000 numbers would probably take
him day and night (preferrably night) for a couple of weeks. This would
give the owner of the card time to report it lost, or at least the
computer might be able to catch the attention of some manager during
working hours. There could be other limits implemented as well, like
the one you first suggested, but I haven't heard about them.

After all, security is relative.
-- 
Anders Andersson, Dept. of Computer Systems, Uppsala University, Sweden
Phone: +46 18 183170
UUCP: andersa@kuling.UUCP (...!{seismo,mcvax}!enea!kuling!andersa)
Re: ATM security (was Re: DES info wanted)
#3602
Author: Kenton Abbott Hoover
Date: Sat, 23 May 1987 21:26
50 lines
3650 bytes
The determination on invalidation is done at the host.  If the programmer wants
to invalidate the card on three attempts, well, then the programmer has to
put a flag on the data record for the card.  An example: Bank Of America (who
I used to work 4) simply sends a report to the branch where your account is
and the branch personel decide whether to flag your card, or just call you
and ask what the h**l is going on.

Trivia:  The Diabold and IBM ATMs (diabolds have CRTs with 4 unmarked buttons,
IBMs say IBM on them, if not they have the cash sort of flop out of a slot and
have an open/closed sign on them) are ...wait for it... 3270 devices!  They]
actually have PF keys and the whole nine yards built-in.

Usual chain of activity in an ATM:

1) The interaction with the user, screens, etc. is done by some sort of
controller, a Series/1-type (read: VERY STUPID) machine which controls 
a whole set of ATMs.  The controller normally resides at some central location
and communicates with the ATMs over leased lines.

2) When you do a transaction, the controller tries to queue up a set of
transactions from its other ATMs.  It will either succeed or timeout. In
either case, the transactions are communicated to a 37X5 and from there
to a mainframe which runs a batch job to do the transaction.

3) Most banks cannot update the account base in real-time, so the ATM
processor (the mainframe doing the batch run, not the ATM itself) works
from a database containing last nights data corrected with todays transactions.
The transaction you actually do is simply made a memo posting and is
entered into the actual accounts system as if it were a teller withdrawl/deposit
with a note saying it was from an ATM.

MORE TRIVIA: The PIN is not a timing issue (in most systems).  Its just that
the whole transaction is usually sent to the mainframe, and that is slow going.

EVEN MORE TRIVIA: Have you ever been cheated out of money by an ATM?  If you
were it was most likely an IBM.  Go to your branch and report it, and they
(after you fill out the usual form) will credit your account.  Save the ATM
receipt, as they normally ask for it.  The IBM machines steal like theives,
and normally (like in socks in dryers) the money has simply vanished.  Diabold
ATMs miscount once in a blue moon, AND if you do a transaction that asks for
more money than is the the ATM (they dont keep track in most cases), it will
give you what it has and debit your account for only that much.

STILL MORE TRIVIA: Dont deposit cash unless it is to a Diabold ATM.  Diabold
ATMs check the deposit envelope to see if there is anything in it.  IBMs dont.
The deposit box is opened by two branch officers, and they (normally) wont
swipe cash from a Diabold, since it would be hard to claim an empty envelope.
However, an IBM machine...

(someone should really write a book on this subject)
Thread Navigation

This is a paginated view of messages in the thread with full content displayed inline.

Messages are displayed in chronological order, with the original post highlighted in green.

Use pagination controls to navigate through all messages in large threads.

Back to All Threads