🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Thread View: uk.comp.os.linux
6 messages
6 total messages Started by Paul Richards Fri, 10 Dec 1999 00:00
Proxy server
#448
Author: Paul Richards
Date: Fri, 10 Dec 1999 00:00
18 lines
1379 bytes
Hi,
I have a dialup box and just for fun I'm thinking of setting up a
http/ftp proxy server.  It would be partly usefull in that I would have
an inter-user web-cache.  I have a few questions though:

If I download something then cancel, will the proxy server thing stop
downloading too?
Does the proxy send the file to the browser as it's being downloaded or
does it sent it to the browser once the whole file is done?
Can I get my proxy to use my ISP's web-cache?

Thats about it really..

TIA
-- 
Paul Richards (Pauldoo)
mailto:pauldoo@dunvegan1.demon.co.uk
http://www.pauldoo.co.uk
Re: Proxy server
#449
Author: Pete Jewell
Date: Fri, 10 Dec 1999 00:00
34 lines
1909 bytes
On Fri, 10 Dec 1999 17:59:45 +0000, Paul Richards 
                 <pauldoo@dunvegan1.demon.co.uk> wrote:
>Hi,
>I have a dialup box and just for fun I'm thinking of setting up a
>http/ftp proxy server.  It would be partly usefull in that I would have
>an inter-user web-cache.  I have a few questions though:
>
>If I download something then cancel, will the proxy server thing stop
>downloading too?

If you're using squid (which I am, having now dumped wwwoffle), then
this is configurable based on the percentage downloaded.  ISTR that the
default is to cancel the download regardless of the percentage.

>Does the proxy send the file to the browser as it's being downloaded or
>does it sent it to the browser once the whole file is done?

Based on observing downloads of large files via squid, it passes on what
it's got as it gets it.

>Can I get my proxy to use my ISP's web-cache?

With squid - yes definately - again, it's a function of the
configuration file - infact you can setup cascading servers, IYSWIM.

HTH

-- 
Pete

pete@maverick-dbms.org
-------------------------------------------------------------
MaVerick - Open Source MultiValue Database Management System
Check out the website     ->    http://www.maverick-dbms.org
Re: Proxy server
#451
Author: Andrew M. Bishop
Date: Sat, 11 Dec 1999 00:00
35 lines
2208 bytes
In newsgroup uk.comp.os.linux,demon.tech.unix
Paul Richards <pauldoo@dunvegan1.demon.co.uk> wrote:
> I have a dialup box and just for fun I'm thinking of setting up a
> http/ftp proxy server.  It would be partly usefull in that I would have
> an inter-user web-cache.  I have a few questions though:

I would suggest that you look at WWWOFFLE if you have a dialup
connection.  You could use something like squid but that won't allow
you to browse while offline, record pages for later download, index
the files that are cached, search the cache (using htdig search
engine), fetch files on a regular basis and many other fun things.

> If I download something then cancel, will the proxy server thing stop
> downloading too?

It is configurable, the default in WWWOFFLE is that it will continue
if the file is 80% or more complete or smaller than 1 kBytes in total.

> Does the proxy send the file to the browser as it's being downloaded or
> does it sent it to the browser once the whole file is done?

As it is being downloaded.

> Can I get my proxy to use my ISP's web-cache?

You can or not, it is configurable in many different ways.

-- 
Andrew.
----------------------------------------------------------------------
Andrew M. Bishop                             amb@gedanken.demon.co.uk
                                      http://www.gedanken.demon.co.uk/

WWWOFFLE users page:
        http://www.gedanken.demon.co.uk/wwwoffle/version-2.5/user.html
Re: Proxy server
#462
Author: Ian Stirling
Date: Mon, 13 Dec 1999 00:00
43 lines
2592 bytes
Andrew M. Bishop <amb@gedanken.demon.co.uk> wrote:
>In newsgroup uk.comp.os.linux,demon.tech.unix
>Paul Richards <pauldoo@dunvegan1.demon.co.uk> wrote:
>> I have a dialup box and just for fun I'm thinking of setting up a
>> http/ftp proxy server.  It would be partly usefull in that I would have
>> an inter-user web-cache.  I have a few questions though:

>I would suggest that you look at WWWOFFLE if you have a dialup
>connection.  You could use something like squid but that won't allow
>you to browse while offline, record pages for later download, index
>the files that are cached, search the cache (using htdig search
>engine), fetch files on a regular basis and many other fun things.


A very nice program, that I'd hate to live without.

However, I've recently run into a couple of problems.

Should I be able to go to the request page, and type
http://user:pass@some.site.org/

As the search string, or is this a "will sometimes work" thing.

I've enocountered various strangenesses, such as 
a fetch for http://USER:PASSWORD@site/ (in netscape, url directly typed)
that's sent to the wwwoffled proxy port correctly,
coming out as 

wwwoffles[8514]: URL='http://user:PASSWORD@host' (With username/password).

If asked for by wwwoffle -o, it works.

(version 2.5)

Is there somewhere I can read up on how passwords are supposed to work
in general, in http, so I can better understand what the code should
do, and why it isn't?

-- 
http://inquisitor.i.am/    |  mailto:inquisitor@i.am |             Ian Stirling.
---------------------------+-------------------------+--------------------------
Get off a shot FAST, this upsets him long enough to let you make your
second shot perfect.                                  -- Robert A Heinlein.
Re: Proxy server
#477
Author: Andrew M. Bishop
Date: Tue, 14 Dec 1999 00:00
64 lines
3523 bytes
In newsgroup uk.comp.os.linux,demon.tech.unix
Ian Stirling <root@mauve.demon.co.uk> wrote:
> Andrew M. Bishop <amb@gedanken.demon.co.uk> wrote:
> >I would suggest that you look at WWWOFFLE if you have a dialup
> >connection.
> 
> A very nice program, that I'd hate to live without.

> However, I've recently run into a couple of problems.
> 
> Should I be able to go to the request page, and type
> http://user:pass@some.site.org/
> 
> As the search string, or is this a "will sometimes work" thing.

If you enter this into the URL box of a browser or the WWWOFFLE
request page then it will get it.

> I've enocountered various strangenesses, such as 
> a fetch for http://USER:PASSWORD@site/ (in netscape, url directly typed)
> that's sent to the wwwoffled proxy port correctly,
> coming out as 
> 
> wwwoffles[8514]: URL='http://user:PASSWORD@host' (With username/password).

This means that the USER:PASSWORD@host has been parsed by WWWOFFLE as
a hostname because the username and password are not displayed in this
informational message.  If you run WWWOFFLE with debugging level of
error reporting (wwwoffled -d 5) you will see the URL split up into
the constituent parts.

I would guess that you have some funny characters in the username or
password (like a '/' in the password which according to RFC 1738
should be replaced by %2f, ':' and '@' also need hex encoding).

For example: if the username is 'user' and the password is '8000/foo'
then the URL you might type is 'http://user:8000/foo@host/' which is
parsed as a hostname and port number.  You should instead have used
'http://user:8000%2ffoo@host/' which is obviously a passworded URL.

I believe that WWWOFFLE does do this parsing correctly, if you can
come up with an actual username and password which does not work then
mail me (it doesn't have to be your real one, just an example that
fails).

> Is there somewhere I can read up on how passwords are supposed to work
> in general, in http, so I can better understand what the code should
> do, and why it isn't?

The HTTP and URL specifications, that would be RFC 1945 for HTTP/1.0,
RFC 2616 for HTTP/1.1 and RFC 1738 for URLs.

WWWOFFLE will convert all URLs of the form http://USER:PASSWORD@site/
into an HTTP request for http://site/ with a Basic authentication
scheme using USER:PASSWORD as the username/password.

-- 
Andrew.
----------------------------------------------------------------------
Andrew M. Bishop                             amb@gedanken.demon.co.uk
                                      http://www.gedanken.demon.co.uk/

WWWOFFLE users page:
        http://www.gedanken.demon.co.uk/wwwoffle/version-2.5/user.html
Re: Proxy server
#480
Author: Ian Stirling
Date: Wed, 15 Dec 1999 00:00
32 lines
2316 bytes
Andrew M. Bishop <amb@gedanken.demon.co.uk> wrote:
>In newsgroup uk.comp.os.linux,demon.tech.unix
>Ian Stirling <root@mauve.demon.co.uk> wrote:

>> I've enocountered various strangenesses, such as 
>> a fetch for http://USER:PASSWORD@site/ (in netscape, url directly typed)
>> that's sent to the wwwoffled proxy port correctly,
>> coming out as 
>> 
>> wwwoffles[8514]: URL='http://user:PASSWORD@host' (With username/password).

>This means that the USER:PASSWORD@host has been parsed by WWWOFFLE as
>a hostname because the username and password are not displayed in this
>informational message.  If you run WWWOFFLE with debugging level of
>error reporting (wwwoffled -d 5) you will see the URL split up into
>the constituent parts.

I'll have a look, and see if I can come up with a broken example.
(complicated by the fact that the site I hit it on, is no longer up)

Hmm, I see I have a directory called ":", in /var/spool/wwwoffle/http/
for what reason I'm not sure (logs purged)
The passwords don't have /'s in, though I had encountered that before,
due to a typo.
Rather annoying, as there was no way of typing the correct password (that
I could find)


-- 
http://inquisitor.i.am/    |  mailto:inquisitor@i.am |             Ian Stirling.
---------------------------+-------------------------+--------------------------
Among a mans many good possessions, A good command of speech has no equal.
Thread Navigation

This is a paginated view of messages in the thread with full content displayed inline.

Messages are displayed in chronological order, with the original post highlighted in green.

Use pagination controls to navigate through all messages in large threads.

Back to All Threads