Article View: comp.mail.headers
Article #248Re: discrepancies between RFC821 and RFC822 (as amended by RFC1123) regarding Received headers
From: Bruce Lilly
Date: Wed, 20 Jan 1993 23:21
Date: Wed, 20 Jan 1993 23:21
31 lines
2148 bytes
2148 bytes
In article <19930118.004@erik.naggum.no>, posted to comp.mail.headers, Erik Naggum <enag@ifi.uio.no> wrote: > >Using the "for" clause doesn't require a database of recipients to messages >and other expensive solutions because the loop detection information is >kept in the message, and it doesn't rely on other sites (which the bogus >"count'em, them drop'em" approach does). Using the for clause properly isn't always easy. You've already alluded to the problem with multiple recipients. Even for a single recipient, there are potential difficulties. RFC822 section 4.3.2 says that the "for" clause is used ``to record the original [address] specification.'' However, it also (sections 4.1 and 6.1) specifies the format, which must be local-part @ domain Some reformatting of the address may be required if it does not arrive in that format (e.g. it may be a source route or it may have come from non-SMTP mail). Also, it is not necessarily guaranteed that the (envelope) address will be unchanged after traversing a path that carries it through several other systems, even if it is indeed a looping message. Comparison of the possibly rewritten envelope address to a possibly rewritten version of an earlier envelope address might not be meaningful. If the format restriction were loosened (particularly also if the revised specification permitted a list of addressees), it would be easier to use this method. Even so, the privacy issue remains a concern. -- Bruce Lilly ...uupsi!monymsys!sonyd1!blilly!bruce
Technical Details
Message-ID:
<1993Jan20.232112.18436@blilly.uucp>Path:
arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!uwm.edu!linac!unixhub!ditka!hico2!sonyd1.broadcast.sony.com!blilly.uucp!bruceReferences:
<1993Jan13.214724.14913@broadcast.sony.com> <1j35s2INNp6g@daisy.ee.und.ac.za> <19930118.004@erik.naggum.no>Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.headers Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!uwm.edu!linac!unixhub!ditka!hico2!sonyd1.broadcast.sony.com!blilly.uucp!bruce From: bruce@blilly.uucp (Bruce Lilly) Subject: Re: discrepancies between RFC821 and RFC822 (as amended by RFC1123) regarding Received headers References: <1993Jan13.214724.14913@broadcast.sony.com> <1j35s2INNp6g@daisy.ee.und.ac.za> <19930118.004@erik.naggum.no> Organization: Bruce Lilly Date: Wed, 20 Jan 93 23:21:12 GMT Message-ID: <1993Jan20.232112.18436@blilly.uucp> Reply-To: lilb@sony.compuserve.com (Bruce Lilly) Lines: 31