Article View: comp.mail.headers
Article #249Re: Headers??? How many formats?
From: oberman
Date: Mon, 25 Jan 1993 22:34
Date: Mon, 25 Jan 1993 22:34
53 lines
3009 bytes
3009 bytes
In article <1993Jan21.234753.20583@blilly.uucp>, bruce@blilly.uucp (Bruce Lilly) writes: > In article <1993Jan19.211424.9632@news.csuohio.edu>, > posted to comp.mail.headers, > damin@ullman.cba.csuohio.edu (Greg Boehnlein) wrote: >> Once the mail was AT these locations, it >>was my job to pick up the mail files in their original format, download >>them to our gateway machines, parse and distribute them, converting in the >>process between the Internet (RFC 822) standards and our FutureNet standards. > > mail != files. > > In order to deliver the messages, you don't want to look at the headers, you > want to look at the envelope address. The same applies to the return > address; it comes from the envelope, not the headers. > > It is perfectly legal to have a message with no To: header and an empty Bcc: > header. > > If you must deal with the message as a stream of characters (or a disk > file), I'd recommend using an SMTP-formatted message, where the envelope > addresses are contained in the SMTP MAIL FROM (or SAML/SOML/SEND FROM) and > RCPT TO commands. This is sometimes called batched SMTP. RFC821 (as amended > by RFC1123) is the SMTP specification. Things are getting closer to the truth. The address to whom mail is delivered is, indeed, the envelope address which is not part of the message. This can lead to some strange messages when the To: line and the envelope differ, but it is NOT unusual. The reply address MAY be the envelope "from" address, but not necessarily. The order of prefererence for reply is rather long, but LOTS of header fields take precidence over the envelope. RFC-822 is quite fuzzy on this, but there can be no question that some fields (e.g. "Reply-To:) must be deferred to. Simply using the envelope "from" field for replys is NOT adequate. The commercial mailer I use determines the corrrect address for replys in the order: Resent-Reply-To: Resent-From: Reply-To: From: Resent-Sender: Sender: envelope "from" address The envelope "from" is pretty much reserved for occasions when there is no useful header information. The RFCs are NOT clear on this order, so some mailers may vary. R. Kevin Oberman Lawrence Livermore National Laboratory Internet: koberman@llnl.gov (510) 422-6955 Disclaimer: Don't take this too seriously. I just like to improve my typing and probably don't really know anything useful about anything.
Technical Details
Message-ID:
<1993Jan25.143459.1@ptavv.llnl.gov>Path:
arc1-ca.pugleaf.net!sparky!uunet!gatech!paladin.american.edu!howland.reston.ans.net!zaphod.mps.ohio-state.edu!uwm.edu!lll-winken!ptavv.llnl.gov!obermanReferences:
<1jh8mbINNqlb@daisy.ee.und.ac.za> <1993Jan19.193144.3580@netcom.com> <1993Jan19.211424.9632@news.csuohio.edu> <1993Jan21.234753.20583@blilly.uucp>Show Full Headers
Complete Article Headers
Path: arc1-ca.pugleaf.net!sparky!uunet!gatech!paladin.american.edu!howland.reston.ans.net!zaphod.mps.ohio-state.edu!uwm.edu!lll-winken!ptavv.llnl.gov!oberman From: oberman@ptavv.llnl.gov Newsgroups: comp.mail.headers Subject: Re: Headers??? How many formats? Message-ID: <1993Jan25.143459.1@ptavv.llnl.gov> Date: 25 Jan 93 22:34:59 GMT References: <1jh8mbINNqlb@daisy.ee.und.ac.za> <1993Jan19.193144.3580@netcom.com> <1993Jan19.211424.9632@news.csuohio.edu> <1993Jan21.234753.20583@blilly.uucp> Sender: usenet@lll-winken.LLNL.GOV Lines: 53 Nntp-Posting-Host: ptavv.llnl.gov