🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: comp.mail.headers
Article #94

Re: can an @domain be numeric?

#94
From: Neil Rickert
Date: Fri, 21 Aug 1992 19:13
16 lines
1024 bytes
In article <9208211741.AA28843@cognition.pa.dec.com> vixie@PA.dec.com (Paul A Vixie) writes:
>rfc822 implies "yes".  many IBM/VM/SMTP mailers seem to say "no" in that
>if they see
>
>	From: user@10.977.enet.dec.com
>
>they yell about the "1" following the "@".

You can't go by RFC822 on this.  RFC822 was apparently written to be
completely general, and not specific to Internet domains.

The format of hostnames is defined in RFC952, and is amended in RFC1123.
The RFC1123 amendmendments specifically allow digits, so the address you
give is OK.

By the way, some IBM/VM/SMTP mailers reject 3com.com also.
Technical Details
Message-ID: <1992Aug21.191340.3743@mp.cs.niu.edu>
Path: arc1-ca.pugleaf.net!sparky!uunet!cs.utexas.edu!sdd.hp.com!ux1.cso.uiuc.edu!mp.cs.niu.edu!rickert
References: <9208211741.AA28843@cognition.pa.dec.com>

Show Full Headers
Complete Article Headers
Newsgroups: comp.mail.headers
Path: arc1-ca.pugleaf.net!sparky!uunet!cs.utexas.edu!sdd.hp.com!ux1.cso.uiuc.edu!mp.cs.niu.edu!rickert
From: rickert@mp.cs.niu.edu (Neil Rickert)
Subject: Re: can an @domain be numeric?
Message-ID: <1992Aug21.191340.3743@mp.cs.niu.edu>
Organization: Northern Illinois University
References: <9208211741.AA28843@cognition.pa.dec.com>
Date: Fri, 21 Aug 1992 19:13:40 GMT
Lines: 17