Thread View: comp.protocols.iso.x400.gateway
2 messages
2 total messages
Started by Harald Tveit Alvestrand
Tue, 26 Feb 1991 09:36
Re: The disjunct-RFC822 domain problem and DD.RFC-822
Author: Harald Tveit Alvestrand
Date: Tue, 26 Feb 1991 09:36
Date: Tue, 26 Feb 1991 09:36
86 lines
4466 bytes
4466 bytes
Bertrand,
I *still* fail to see your point.
I may be unusually thick.....
The example address is user%host.decnet@cs.manchester.ac.uk
>
> The correct gatewayed address is
>
> C=GB;A= ;P=AC.UK;O=mhs-relay;DD.RFC-822= ...
>
I am not sure about that.
I would assume that the gatewayed address is generated by a gateway that
gets a message from Manchester on SMTP, and wants to generate an X.400
address.
We then have 2 cases:
1) The gateway has a table entry for it, for example the one you use.
2) The gateway does NOT have a table entry for it, so it uses SAs that
will lead to the message being routed back to the SAME gateway.
Since the gateway got the message from Manchester by SMTP in the first
place, it seems not unreasonable to impose the condition that it be able
to return the message to Manchester using SMTP.
> Suppose, on another hand, that there exists a real X.400 domain at Manchester
> which as exactly the same SA as in the above example. There will be no
> User Agent at Manchester which will be able to deliver a mail with the
> above address. Unfortunately, this kind of situation will occur each
> time that there is an overlap between the X.400 name space and the Internet
> name space (the both name spaces being mapped onto each other using the
> current RFC 987 mapping tables).
>
We have exactly this problem in UNINETT.
We have several domains sharing address space.
We have found 2 solutions:
1) The addresses may be sorted using O and OU fields only.
The MX records for the X.400 parts point to UNINETT's gateways, and the
tables on UNINETT's gateways are able to sort correctly.
The MX records for the SMTP parts point directly to the machines involved.
All other X.400 MTAs do one of two things:
- Route the message to the X.400 MTA for the subdomain, where some messages
get sent on to the UNINETT gateways for relaying to SMTP
- Route all the mail through one of the UNINETT central machines, which
sort correctly.
2) The addresses may NOT be sorted using O and OU.
In this case, we require that the organization operate its own RFC-987
gateway, and each network sends its mail (X.400 or SMTP) to that gateway.
ELAB-RUNIT (my organization) is such an organization.
In both cases, all addresses are reachable from both the SMTP world and the
X.400 world, without any gateway table required.
Your other problem:
>
> Having a gateway table could also solve a couple of other current problems
> of RFC 987. I'll just cite on problem which is causing a lot of trouble
> to our users :
>
> RFC 987 ask to set the P1.PerRecipientFlag to Confirmed if we want to
> have message contents returned in case of non delivery.
Can you give me chapter and verse on this one, please?
(Steve, one suggestion for RFC-1148/2: INCLUDE AN INDEX!!!!)
> <the users think that mail has arrived when it has been gatewayed,
> because the gateway returns a DR>
> If a gateway table was present, we could set the PerRecipientFlag
> to Basic (just asking for Non-Delivery Reports) because the table will tell
> us that the recipient address is in a RFC-822 domain.
Now you are asking to present the Gateway Table to the users.
I do not like to do this...they are MORE than enough confused if required
to read the mapping tables :-(((((((((((
The basic problem is probably that EAN does not present the Supplementary
Information field of the X.400 DeliveryReport to the user.
If this said something like "GATEWAYED TO THE INTERNET", your users would
probably stop complaining.
This is one thing that I have suggested that the EAN Support Team take
as an important action item.
(it SHOULD say something like that. See RFC 987, section 4.4.2, page 35)
So, why do we need the gateway table?
harald Tveit Alvestrand
(I got this on Email first, so this is an EMailed reply. Long live the
confusion!)
Delivery Reports and tunnelling
Author: Bertrand Buclin
Date: Thu, 28 Feb 1991 00:06
Date: Thu, 28 Feb 1991 00:06
59 lines
3597 bytes
3597 bytes
>> >> Having a gateway table could also solve a couple of other current problems >> of RFC 987. I'll just cite on problem which is causing a lot of trouble >> to our users : >> >> RFC 987 ask to set the P1.PerRecipientFlag to Confirmed if we want to >> have message contents returned in case of non delivery. > >Can you give me chapter and verse on this one, please? >(Steve, one suggestion for RFC-1148/2: INCLUDE AN INDEX!!!!) RFC-987, clause 5.3, second paragraph (page 47). >> If a gateway table was present, we could set the PerRecipientFlag >> to Basic (just asking for Non-Delivery Reports) because the table will tell >> us that the recipient address is in a RFC-822 domain. > >Now you are asking to present the Gateway Table to the users. Absolutely not. When I write "we", you sould read the gateway implementor/ operator. Of course, mapping tables are not in (normal) human-readable form... >The basic problem is probably that EAN does not present the Supplementary >Information field of the X.400 DeliveryReport to the user. >If this said something like "GATEWAYED TO THE INTERNET", your users would >probably stop complaining. It is not an EAN problem (nor PP or Mailway or any other gateway), it's a protocol problem. Ok, RFC-987 says an indication of the nature of the gateway should be included in the report, but I think that in the very case of tunnelling (=using an X.400 network to interconnect two SMTP nets) the Report Request bits in P1.PerRecipientFlag should be set to Basic and not Confirmed. Consider the different case one can encounter : - The message is delivered to its recipient (normal case). The users are used to receive no acknoledge of their messages in SMTP world. Using Basic flag will make then the X.400 tunnel transparent - There is an while the mail is in the X.400 world. A DR is generated reporting that error. The user is informed and everything is fine. - There is an error while the mail is back in SMTP world. Then the normal SMTP error reporting mechanisms will generate an error message which will be delivered to the originator. Normally, a DR is associated with a given message, and in most X.400 implementations, it is handled by the UA (by just informing the user that a DR has arrived for a given message and then associating the DR with the message). The way RFC-987 proposes to map DR is confusing for the end user, and of course no RFC-822 user agent can handle DR the same way an X.400 UA does. -- Bertrand Buclin Internet: Buclin@Sic.Epfl.CH Service Informatique Central X.400: C=CH;A=ARCOM;P=SWITCH; Ecole Polytechnique Federale de Lausanne O=EPFL;OU=SIC;S=Buclin; CH-1015 Lausanne Tel: +41 21 693 22 11 (Switzerland) Fax: +41 21 693 22 20
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads