Thread View: comp.protocols.iso.x400.gateway
2 messages
2 total messages
Started by Christian Huitema
Thu, 28 Feb 1991 12:30
RFC-1148/2: what about underlines
Author: Christian Huitema
Date: Thu, 28 Feb 1991 12:30
Date: Thu, 28 Feb 1991 12:30
40 lines
2041 bytes
2041 bytes
The current version of RFC-1148 contained a bug. By mistake, it was recommended to apply the following transformations between RFC-822 strings and X.400 Printable strings: map space(RFC) to space(X.400) map underline(RFC) to escape sequence (u) This has proven to be very inadequate for the following reasons: * underline is very frequently used in RFC "local parts". * space is almost never used in native RFC local parts. * the usage of the escape sequence "(u)" in an X.400 surname is akward, and puzzles regular X.400 users. * the usage of spaces in RFC local parts implies the quoting of the local part. This quoted addresses cannot be supported by some networks (e.g. UUCP). They tend to confuse some widely deployed user agents like the standard unix mailer "/bin/mail" and the standard Berkeley 4.[23] mailer. In order to cope with this problem, a number of local solutions have been deployed, e.g. development of UUCP specific mappings or local decisions to deviate from the RFC. This partial solutions are clearly undesirables, as they tend to jeopardize the global connectivity and introduce non reversible mappings. In order to enhance the interconnectivity, I suggest to adopt the following bug correction: map underline(RFC) to space(X.400) map space(RFC) to escape sequence (u) In order to protect existing software, we could perhaps establish a caveat so that "when the local part is quoted, no mapping of characters should be performed". But this should clearly come with a strong incentive to not use the "quoted" expression when this can be avoided. Christian Huitema
Re: RFC-1148/2: what about underlines
Author: Bertrand Buclin
Date: Wed, 06 Mar 1991 08:30
Date: Wed, 06 Mar 1991 08:30
37 lines
2372 bytes
2372 bytes
>In order to enhance the interconnectivity, I suggest to adopt the following >bug correction: > >map underline(RFC) to space(X.400) >map space(RFC) to escape sequence (u) Why not map space to "(s)", it's more regular than "(u)" ? >In order to protect existing software, we could perhaps establish a caveat >so that "when the local part is quoted, no mapping of characters should be >performed". But this should clearly come with a strong incentive to not use >the "quoted" expression when this can be avoided. This could just add some more confusion. If a quoted address is mapped without character mapping, how will you detect once it is in X.400 world that it was initially quoted ? Exemple : "Bertrand Buclin"@Sic.Epfl.ch will according to your suggestion map to : S=Bertrand Buclin;OU=Sic;... When the message arrives from X.400 to an RFC-xxxx gateway, you will map the address back to : Bertrand_Buclin@Sic.Epfl.CH, which is clearly not the same address ! The defined mapping MUST be reversible and non ambiguous ! >In order to enhance the interconnectivity, I suggest ... That RFC-1148bis be also a revision of RFC-987 (officially). Except RFC1026 there has been (officially) no revision of RFC-987. I agree that part of RFC-1148 could also apply to X.400(84), but it needs to be stated. -- Bertrand Buclin Internet: Buclin@Sic.Epfl.CH Service Informatique Central X.400: C=CH;A=ARCOM;P=SWITCH; Ecole Polytechnique Federale de Lausanne O=EPFL;OU=SIC;S=Buclin; CH-1015 Lausanne Tel: +41 21 693 22 11 (Switzerland) Fax: +41 21 693 22 20
Thread Navigation
This is a paginated view of messages in the thread with full content displayed inline.
Messages are displayed in chronological order, with the original post highlighted in green.
Use pagination controls to navigate through all messages in large threads.
Back to All Threads