🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Thread View: comp.protocols.iso.x400.gateway
1 messages
1 total messages Started by Steve Kille Wed, 13 Mar 1991 04:43
Re: RFC-1148/2: what about underlines
#138
Author: Steve Kille
Date: Wed, 13 Mar 1991 04:43
53 lines
2950 bytes
Christian,

I've not had a flame at you for ages!

 >From:  Christian Huitema <Christian.Huitema@fr.inria.mirsa>
 >To:    Steve Kille <S.Kille@uk.ac.ucl.cs>
 >Subject: RFC-1148/2: what about underlines
 >Date:  Thu, 28 Feb 1991 12:13:47 +0100

 >The current version of RFC-1148 contained a bug. By mistake, it was
 >recommended to apply the following transformations between RFC-822 strings and
 >X.400 Printable strings:

This is not a bug and you know it.  This issue was discussed at the 1148
editing meeting at UCL.  You said that the space/_ mapping was needed, but
the meetings concencus was not to do it.  Clearly, old discussions can be
reopened, but to pretend that they are new issues/suprises is not good
behaviour.

RFC 987 fudged the issue, by placing this mapping (and a set of others)
in an appendix and not clearly stating when the appendix should be used.
With 1148, we factored out this mapping into a separate RFC (1137), to be
used when traversing between full 822 and restricted 822 networks.  There
are a number of (more pathological) cases than space/_ covered.
(Incidentally, 1137 should probably be updated to deal with this new UUCP
which does not accept "/" problem).

The real issue is: "Does RFC 822 support quoted string mappings, and
in particular quoting of space".

If this is the case, then anything claiming to follow 822 should support
this.  Any network which cannot support it should use 1137 as a gateway
mechanism.  The approach in 1148 of mapping space in X.400 to space in RFC
822 is clearly the most desirable.  For an 822 user, this means that X.400
addresses can be inserted with no character transpositions.   An X.400 user
has to know about several acharacter encodings to input RFC 822 addresses -
and in particular (a).  All the encodings have the same style, and so (u) for
underscore is certainly a better choice that space.  You would get into a
horrible mess in dealing with an 822 address which contained space (these do
exist).

If this is not the case - for example if it is a recognised fact that this
usage causes problems and should be deprecated, then this should be noted.
There is a mechanism to do this, which is the host requirements.
If you really believe that quoted space is a problem on the Internet (I do
not), then this document should be changed.  Otherwise, it should be used as
a stick to get any broken implementations mended.


 >Christian Huitema


Steve
Thread Navigation

This is a paginated view of messages in the thread with full content displayed inline.

Messages are displayed in chronological order, with the original post highlighted in green.

Use pagination controls to navigate through all messages in large threads.

Back to All Threads