Article View: de.admin.news.misc
Article #181Re: MIME im USENET (war: Umlaute)
From: Andreas Ley
Date: Wed, 14 Oct 1992 14:10
Date: Wed, 14 Oct 1992 14:10
33 lines
2664 bytes
2664 bytes
In article <Bw3zMz.7rw@immd4.informatik.uni-erlangen.de>, mskuhn@immd4.informatik.uni-erlangen.de (Markus Kuhn) writes: |> ry66@rz.uni-karlsruhe.de (Andreas Ley) writes: |> >RFC-1341 bis RFC-1344, gilt fuer Mail, das ist richtig, aber RFC-1036 sagt, dass |> >News nix anders sind als erweiterte Mails: |> Dennoch fehlt da meiner Meinung nach noch eine winzige RFC, damit die |> Definition wasserdicht ist. Im Unterschied zum Mailsystem (dass ja meist ueber |> das 7-bit Protokoll RFC821=SMTP gejagt wird) sind die USENET-sites dieser |> Welt _fast_ alle 8-bit transparent, so dass wir bei MIME/News standardmaesig |> die in MIME auch definierte 8-bit oder binary Encoding benutzen sollten. Kein Problem, RFC-1036 bezieht sich ja nur auf RFC-822 und nicht auf RFC-821, wo das mit den 7bit festgelegt ist - von daher koennen News auch 16-bit-chars enthalten, falls Mail das erlaubt... Allerdings steht in der NNTP-Definition wieder 7bit drin, ich weiss nicht, ob das im NNTP2 dann beseitigt ist. Jeden- falls betrifft das nur das Protokoll, nicht die Art wie 'ne msg aussieht - und da kann man sich ja mit News durchaus von Mail absetzen. |> Ich will keine Sonderbehandlung fuer meine Umlaute!!! |> Alle Buchstaben sind gleich. Nur sind eben manche gleicher als andere ... |> Apropos: ist unido inzwischen 8-bit transparent geworden? Schon lang... nur der uucp-server ist glaub ich noch 7bit, die nntp-site ist 8bit-clean. Ach ja, und weil das auch schon aufgetaucht ist: Umlaute sollten wenn als ISO88591's kommen, nicht als PC850 (oder wie das heisst)... ausnahms- weise ist BIM hier mal nicht der Standard... Bye, Andy ------------------------------------------------------------------------------- Andreas Ley ! "Even when you're ! Email: ley@rz.uni-karlsruhe.de Nelkenstr. 9 ! a genius, life is ! s_ley@irav1.ira.uka.de W-7500 Karlsruhe 1 ! a mystery!" ! RY66@DKAUNI2.BITNET Germany ! Doogie Howser, M.D. ! Voice: +49 721 84 10 36
Technical Details
Message-ID:
<1992Oct14.141004.25560@rz.uni-karlsruhe.de>Path:
arc1-ca.pugleaf.net!sparky!uunet!spool.mu.edu!darwin.sura.net!zaphod.mps.ohio-state.edu!sol.ctr.columbia.edu!ira.uka.de!rz.uni-karlsruhe.de!rz.uni-karlsruhe.de!ry66References:
<1992Oct9.185001.12109@rz.uni-karlsruhe.de> <Bw3zMz.7rw@immd4.informatik.uni-erlangen.de>Show Full Headers
Complete Article Headers
Newsgroups: de.admin.news.misc Path: arc1-ca.pugleaf.net!sparky!uunet!spool.mu.edu!darwin.sura.net!zaphod.mps.ohio-state.edu!sol.ctr.columbia.edu!ira.uka.de!rz.uni-karlsruhe.de!rz.uni-karlsruhe.de!ry66 From: ry66@rz.uni-karlsruhe.de (Andreas Ley) Subject: Re: MIME im USENET (war: Umlaute) Message-ID: <1992Oct14.141004.25560@rz.uni-karlsruhe.de> Sender: usenet@rz.uni-karlsruhe.de (USENET News System) Reply-To: ley@rz.uni-karlsruhe.de Organization: University of Karlsruhe, Germany References: <1992Oct9.185001.12109@rz.uni-karlsruhe.de> <Bw3zMz.7rw@immd4.informatik.uni-erlangen.de> Date: Wed, 14 Oct 1992 14:10:04 GMT Lines: 33