Article View: de.admin.news.software
Article #19Re: opinion poll: Akzeptanz von ISO-Umlauten
From: Carsten Rossenhoevel
Date: Sat, 25 Jul 1992 19:18
Date: Sat, 25 Jul 1992 19:18
91 lines
4749 bytes
4749 bytes
heiko@Groucho.Chemie.FU-Berlin.DE (Heiko Schlichting) writes:
> Richtig. nur hat MIME nicht das geringste mit USENET-News zu tun.
Nein???? Ich dachte immer, RFC822 spezifiziert das Message Format
fuer alle Arten von Internet Text Messages, also auch Mail und News.
MIME erweitert RFC822. (erweitern im Sinne von "update" im RFC Jargon)
> Es steht
> auch nicht im MIME-Dokument, dass Du einfach Umlaute in die Mail kleisterst
> und das verschickst - also mach da gefaelligst auch nicht in den News.
Hatte ich gesagt: Uebertragungsformat hat nichts mit dem Zeichensatz
zu tun. Umlaute in die Mail kleistern ;-) kann ich soviel ich will.
Sie dann unkodiert zu verschicken, ist eine andere Sache. Mir ist auch
nicht ganz wohl bei der 8-bit-Uebertragung, aber nochmal: Das hat
*NICHTS* mit dem Zeichensatz zu tun.
> Von mir aus kannst Du ja einen X-...-Header vorschlagen und die Sachen dann
> encoded posten. So wuerdest Du es ja auch bei MIME machen, wenn es ueber
> nicht 8-bit-transparente Software laufen soll.
Richtig. Aber ohne X-Header, gips alles schon. Das von MIME
vorgeschlagene encoding hat nur einen Nachteil: Es ist (aus offen-
sichtlichen Gruenden) nicht lesbar ohne zusaetzliche Software auf
der Empfangsseite.
RFC1341 definiert:
Content-Transfer-Encoding := "BASE64" / "QUOTED-PRINTABLE" /
"8BIT" / "7BIT" /
"BINARY" / x-token
7bit
-- default, no encoding, RFC822: 'kurze' Zeilen (~ < 75 Zeichen)
Beispiel: Das Wort 'äußeres' wird um die MSBs beraubt als
'du_eres' dargestellt oder muss vom UA/Benutzer anders codiert
werden.
8bit
-- wie 7bit, aber das 8. Bit darf gesetzt sein.
'äußeres' == 'äußeres'
binary
-- wie 8bit, aber keine Zeilenlaengenbeschraenkung
'äußeres' == 'äußeres'
quoted-printable
-- jedes 8-bit-Zeichen kann hexadezimal mit vorgestelltem '='
codiert werden. Einige ASCII-Zeichen duerfen normal dargestellt
werden. Soft linebreaks werden durch '=' am Ende der Zeile
codiert. Whitespace darf nicht am Ende einer Zeile stehen.
'äußeres' == '=E4u=DFeres'
base64
-- benutzt nur 64 Zeichen aus dem ASCII-Vorrat, die auch in EBCDIC
und in ISO646 (die alten National Replacement Character Sets,
'äußeres' == '{u|eres' oder so) die gleiche Bedeutung haben.
Drei 8-bit-Bytes Inputstream werden in vier Byte Outputstream
codiert und ueber eine Tabelle in zugeordnete ASCII-Zeichen
verschluesselt.
'äußeres' -> e475df65726573 -> 111001 000111 010111 011111 011001
010111 001001 100101 011100 110000 -> (dec) 57 07 23 31 25 23 09
37 28 48 -> '5HXfZXJlcw'
Wie MIME und RFC1113 treffend sagen: "not humanly readable".
Nun ja. Ich finde weder quoted-printable noch base64 fuer News passend.
Ausserdem sind demnaechst alle wesentlichen MTAs in Deutschland clean;
fuer UAs haben Markus Kuhn und andere Konverter von ISO-Umlaut nach
ASCII-Umschrift vorgeschlagen.
Aber nochmal MIME zum Thema `illegale Kodierungen':
As of the publication of this document, there are no
standardized Internet transports for which it is legitimate
to include unencoded 8-bit or binary data in mail bodies.
Thus there are no circumstances in which the "8bit" or
"binary" Content-Transfer-Encoding is actually legal on the
Internet. However, in the event that 8-bit or binary mail
transport becomes a reality in Internet mail, or when this
document is used in conjunction with any other 8-bit or
binary-capable transport mechanism, 8-bit or binary bodies
should be labeled as such using this mechanism.
Was heisst "in the event that 8-bit [..] transport becomes a reality"?
Das laesst sich natuerlich unterschiedlich interpretieren ;-)
seufz, Carsten
--
Carsten Rossenhövel <cross@cs.tu-berlin.de>
Technical Details
Message-ID:
<8WF5QMB@mailgzrz.tu-berlin.de>Path:
arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!sol.ctr.columbia.edu!ira.uka.de!math.fu-berlin.de!zrz.tu-berlin.de!crossReferences:
<ARF57FS@math.fu-berlin.de> <YSF58LV@mailgzrz.tu-berlin.de> <KUF5GIV@math.fu-berlin.de>Show Full Headers
Complete Article Headers
Newsgroups: de.admin.news.software Path: arc1-ca.pugleaf.net!sparky!uunet!zaphod.mps.ohio-state.edu!sol.ctr.columbia.edu!ira.uka.de!math.fu-berlin.de!zrz.tu-berlin.de!cross From: cross@cs.tu-berlin.de (Carsten Rossenhoevel) Subject: Re: opinion poll: Akzeptanz von ISO-Umlauten Content-Type: text/plain; charset=ISO-8859-1 Message-ID: <8WF5QMB@mailgzrz.tu-berlin.de> Sender: news@mailgzrz.tu-berlin.de (News Manager) Nntp-Posting-Host: pound.cs.tu-berlin.de Content-Transfer-Encoding: 8bit Organization: FB20 unbundled References: <ARF57FS@math.fu-berlin.de> <YSF58LV@mailgzrz.tu-berlin.de> <KUF5GIV@math.fu-berlin.de> Mime-Version: 1.0 Date: Sat, 25 Jul 1992 19:18:16 GMT Lines: 91