๐Ÿš€ go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Article View: fj.net.mime
Article #157

Re: encoded-word

#157
From: Tanaka Akira
Date: Sat, 11 Jul 1998 00:00
44 lines
3100 bytes
In article <96g7o6.kv5.ln@sou.nerv.org>,
  Kazushi Jam Marukawa <jam@pobox.com> writes:

> ใ‚ใ‚‹ใ‚“ใงใ™ใŒใ€'comment'ไธญใฎ"("ใจ")"ใจ"ใฏใ€"Q"ใ‚จใƒณใ‚ณใƒผใƒ‰ใ—ใกใ‚ƒ
> ใ„ใ‘ใชใ„ใ‚“ใ ใใ†ใงใ™ใ€‚5.ใฎใƒซใƒผใƒซ2ๅ‚็…งใ€‚

ใ†ใ…ใ‚€ใ€‚encoded-word ใŒ character ใ‚’ contain ใ™ใ‚‹ใจใฏใฉใƒผใ‚†ใƒผใ“ใจใ‹,
ใฃใฆใ“ใจใซ้–ขใ™ใ‚‹่งฃ้‡ˆใฎ็›ธ้•, ใฃใฆใ‚„ใคใงใ™ใญใ€‚

็งใฏใ“ใ‚Œใ‚’ใ‚จใƒณใ‚ณใƒผใƒ‰ใ•ใ‚ŒใŸ US-ASCII ใฎๆ–‡ๅญ—ๅˆ—ๅ†…ใซ "(", ")", "\" ใŒๅซใพ
ใ‚Œใชใ„ใจ่งฃ้‡ˆใ—ใพใ—ใŸใ€‚

# ใ‚, RFC2047(ใจ RFC1522)ใฏๆ–‡ๆ›ธใฎๆ•ดๅฝขใฎๅคฑๆ•—ใชใฎใ‹ใใฎ่กŒใŒๅˆ‡ใ‚Œใฆใพใ™ใ€‚
# ๅˆ‡ใ‚Œใฆใ„ใ‚‹ๅ†…ๅฎนใŒ "\" ใงใ‚ใ‚‹ใ“ใจใฏ, RFC1342 ใพใง้กใ‚‹ใจใ‚ใ‹ใ‚Šใพใ™ใ€‚

"(", ")", "\" ใ‚’ๆ›ธใ„ใฆใฏใ„ใ‘ใชใ„ใฎใฏ, ใใฎใธใ‚“ใŒ encoded-word ใซๅซใพใ‚Œ
ใฆใ„ใ‚‹ใจ RFC822 ใซใ‚ˆใ‚‹ parse ใ‚’ๅคฑๆ•—ใ™ใ‚‹ใ‹ใ‚‰ใ ใจ็†่งฃใ—ใฆใ„ใพใ™ใ€‚ใ ใ‹ใ‚‰
ใ‚จใƒณใ‚ณใƒผใƒ‰ใ•ใ‚ŒใŸๅฝขใง็พใ‚Œใ‚‹ใฎใฏใพใฃใŸใๅ•้กŒใŒใชใ„ใจๆ€ใ„ใพใ™ใ€‚

# ๅ•้กŒ: ไธŠ่จ˜ใฎ RFC2047 ใฎๅˆถ้™ใŒใชใ‹ใฃใŸใจใ—ใฆ, ๆฌกใฎ To: ใฎๅฎ›ๅ…ˆใฏใฉใ“ใ‹?
# To: (=?US-ASCII?Q?(?=)akr@jaist.ac.jp(=?US-ASCII?Q?))jam@pobox.com(?=)

>    > RFC822 ใฎๆ–‡ๆณ•ใฏ, US-ASCII ใฎๆ–‡ๅญ—ๅˆ—(ใพใŸใฏใƒใ‚คใƒˆๅˆ—)ใจๆง‹ๆ–‡ๆœจใฎใ‚ใ„ใ ใฎๅฏพ
>    > ๅฟœใ‚’็คบใ—ใฆใ„ใพใ™ใ€‚ใใ—ใฆ, RFC2047 ใฏใใฎๆง‹ๆ–‡ๆœจใฎๅค‰ๆ›่ฆๅ‰‡ใ‚’ๅฎš็พฉใ—ใฆใ„ใพ
>    > ใ™ใ€‚
> 
> ใงใ™ใญใ€‚ใใ‚‚ใใ‚‚ใƒ‡ใ‚ณใƒผใƒ‰ใงใใชใ„(MIME้žๅฏพๅฟœใฎ)ๅฏ่ƒฝๆ€งใ‚‚ใ‚ใ‚‹ใ‚ใ‘ใงใ€
> ๅƒ•ใฎ่ฉฑใฏใกใ‚‡ใฃใจๅค‰ใงใ™ใญใ€‚ใƒœใ‚ฑใฆใŸใ‚ˆใ†ใงใ™ใ€‚ๅ˜็ด”ใซ"B"ใชใ‚‰ใ„ใ„
> ใจใ„ใ†่ฉฑใ˜ใ‚ƒใชใ„ใงใ™ใญใ€‚

ใฆใ‚†ใƒผใ‹, ใƒ‡ใ‚ณใƒผใƒ‰ใ—ใชใใฆใ‚‚ MTA ใŒๆ‰ฑใˆใชใ„ใจใ„ใ‘ใชใ„ใฆใ„ใ†ใฎใŒ, ใ“ใฎ
ไธ€่ฆ‹ๅฅ‡ๅฆ™ใซใ‚‚ๆ€ใˆใ‚‹้šŽๅฑคๆง‹้€ ใŒไฝœใ‚‰ใ‚ŒใŸ็†็”ฑใ ใจๆ€ใ„ใพใ™ใŒใ€‚

ใกใชใฟใซ, MUA ใŒ MIME ใซๅฏพๅฟœใ—ใฆใŸใฃใฆใƒ‡ใ‚ณใƒผใƒ‰ใงใใชใ„ๅฏ่ƒฝๆ€งใ‚‚ใ‚ใ‚Šใพใ™ใ€‚
็Ÿฅใ‚‰ใชใ„ charset ใŒใคใ„ใฆใ„ใ‚‹ใ“ใจใŒใ‚ใ‚Šใพใ™ใ‚“ใงใ€‚
ใ“ใฎๅ ดๅˆ, ใ€Œ่ฌŽใฎๆ–‡ๅญ—ๅˆ— =?...?.?...?=ใ€ใจใ„ใ†ใ‚ˆใ†ใช่ฆ็ด ใŒๆง‹ๆ–‡ๆœจใซๅซใพใ‚Œ
ใ‚‹ใ“ใจใซใชใ‚Šใพใ™ใ€‚

# encoded-word ใฎใพใพใฎ US-ASCII ใฎๆ–‡ๅญ—ๅˆ—ใซใ€Œใƒ‡ใ‚ณใƒผใƒ‰ใ€ใ™ใ‚Œใฐใ„ใ„ใ‚“ใ˜ใ‚ƒ
# ใชใ„ใฎ, ใจใ„ใ†ใฎใฏใกใ‚‡ใฃใจ็”˜ใ„่€ƒใˆใงใ™ใ€‚encoded-word ใฎๅฝขใ‚’ใ—ใŸๆ–‡ๅญ—
# ๅˆ—ใ‚’ๆ‰ฑใˆใชใ„ใจใ„ใ†ๅ•้กŒใ‚’็„ก่ฆ–ใ—ใฆใ‚‚, ๅฅ‡ๅฆ™ใชใ“ใจใŒ่ตทใ“ใ‚‹ๅฏ่ƒฝๆ€งใŒใ‚ใ‚Šใพ
# ใ™ใ€‚
-- 
[็”ฐไธญ ๅ“ฒ][ใŸใชใ‹ ใ‚ใใ‚‰][Tanaka Akira]
Technical Details
Message-ID: <rsq4swo1su0.fsf@is27e1s03.jaist.ac.jp>
Path: arc1-ca.pugleaf.net!unknown!not-for-mail
References: <KATE.98Jul9193034@yamato.trad.pfu.co.jp> <rsqzpejf9hp.fsf@is27e1s03.jaist.ac.jp> <9b07o6.bud.ln@sou.nerv.org> <rsq3ec8r94n.fsf@is27e1s03.jaist.ac.jp> <96g7o6.kv5.ln@sou.nerv.org>

Show Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS
X-Google-Thread: 100bbf,1a07400fac91910c
X-Google-Attributes: gid100bbf,public
From: Tanaka Akira <akr@jaist.ac.jp>
Subject: Re: encoded-word
Date: 1998/07/11
Message-ID: <rsq4swo1su0.fsf@is27e1s03.jaist.ac.jp>
X-Deja-AN: 370475423
References: <KATE.98Jul9193034@yamato.trad.pfu.co.jp> <rsqzpejf9hp.fsf@is27e1s03.jaist.ac.jp> <9b07o6.bud.ln@sou.nerv.org> <rsq3ec8r94n.fsf@is27e1s03.jaist.ac.jp> <96g7o6.kv5.ln@sou.nerv.org>
Content-Type: text/plain; charset=ISO-2022-JP
X-Emacs: Emacs 20.2, MULE 3.0 (MOMIJINOGA)
Organization: JAIST, Hokuriku; Tatsunokuchi, Nomi, Ishikawa, Japan
Mime-Version: 1.0 (generated by SEMI 1.8.4 - "Takaoka")
User-Agent: Semi-gnus/6.8.0 Emacs/20.2 Mule/3.0 (MOMIJINOGA)
Newsgroups: fj.net.mime