Article View: fj.net.mime
Article #158Re: encoded-word
From: Kazushi Jam Marukawa
Date: Sat, 11 Jul 1998 00:00
Date: Sat, 11 Jul 1998 00:00
43 lines
3100 bytes
3100 bytes
Tanaka Akira <akr@jaist.ac.jp> wrote:
> In article <96g7o6.kv5.ln@sou.nerv.org>,
> Kazushi Jam Marukawa <jam@pobox.com> writes:
>> あるんですが、'comment'中の"("と")"と"は、"Q"エンコードしちゃ
>> いけないんだそうです。5.のルール2参照。
> # あ, RFC2047(と RFC1522)は文書の整形の失敗なのかその行が切れてます。
> # 切れている内容が "\" であることは, RFC1342 まで遡るとわかります。
あ、やっぱり。何か変だと思ってました。
"じゃなくて"\"なんですね。報告されました?
> 私はこれをエンコードされた US-ASCII の文字列内に "(", ")", "\" が含ま
> れないと解釈しました。
> "(", ")", "\" を書いてはいけないのは, そのへんが encoded-word に含まれ
> ていると RFC822 による parse を失敗するからだと理解しています。だから
> エンコードされた形で現れるのはまったく問題がないと思います。
なんか立場が変では?田中さんは"("を")"という構造を保存する
ために、エンコードしてはいけないという立場ではないんですか?
そもそも、RFC822の'comment'のctextに"("、")"、"\"が含まれ
ないため、ctextに相当する物をエンコードした物であるはずの
encoded-wordにも含まれちゃまずいんだろうってのが妥当では。
田中さんも、同様に考えて、「RFC822の構文」と述べたんだと
思って、そしてその立場からすると、エンコードして表われる
のもまずいんじゃないかと思ってたのですが。
MIMEで何故、そういった説明がなく、規則2みたいに例示で済まし
てるかというと、これは完全に想像なんだけど、説明が面倒なんで、
これらは駄目よと一言言って済ましたんじゃないかと。
なのに何故先刻は"B"でエンコードすればと言ったのという
突っ込みには、ボケてたからとしか言いようがないです。
> # 問題: 上記の RFC2047 の制限がなかったとして, 次の To: の宛先はどこか?
> # To: (=?US-ASCII?Q?(?=)akr@jaist.ac.jp(=?US-ASCII?Q?))jam@pobox.com(?=)
何も考えずデコードして、(()akr@jaist.ac.jp())jam@pobox.com()って
ことで、jam@pobox.comでいいんじゃないかと。でも本来なら、先に
パースして個々のctextに分かれちゃうので、デコードできないと。
-- かずし
Technical Details
Message-ID:
<ejp7o6.8l6.ln@sou.nerv.org>Path:
arc1-ca.pugleaf.net!unknown!not-for-mailReferences:
<96g7o6.kv5.ln@sou.nerv.org> <rsq4swo1su0.fsf@is27e1s03.jaist.ac.jp>Show Full Headers
Complete Article Headers
X-Google-Language: Japanese,JIS X-Google-Thread: 100bbf,1a07400fac91910c X-Google-Attributes: gid100bbf,public From: Kazushi Jam Marukawa <jam@pobox.com> Subject: Re: encoded-word Date: 1998/07/11 Message-ID: <ejp7o6.8l6.ln@sou.nerv.org> X-Deja-AN: 370478366 Content-Transfer-Encoding: 7bit Sender: Kazushi (Jam) Marukawa <jam@sou.nerv.org> References: <96g7o6.kv5.ln@sou.nerv.org> <rsq4swo1su0.fsf@is27e1s03.jaist.ac.jp> Content-Type: text/plain; charset=iso-2022-jp X-Complaints-To: abuse@io.com X-Trace: hiram.io.com 900155717 361 131.193.40.109 (11 Jul 1998 11:15:17 GMT) Organization: none Mime-Version: 1.0 User-Agent: tin/pre-1.4-980704 (UNIX) (NetBSD/1.3F (i386)) NNTP-Posting-Date: 11 Jul 1998 11:15:17 GMT Newsgroups: fj.net.mime