🚀 go-pugleaf

RetroBBS NetNews Server

Inspired by RockSolid Light RIP Retro Guy

Thread View: comp.mail.headers
4 messages
4 total messages Started by Paul A Vixie Fri, 21 Aug 1992 17:41
can an @domain be numeric?
#93
Author: Paul A Vixie
Date: Fri, 21 Aug 1992 17:41
14 lines
1072 bytes
rfc822 implies "yes".  many IBM/VM/SMTP mailers seem to say "no" in that
if they see

	From: user@10.977.enet.dec.com

they yell about the "1" following the "@".

we're trying to design an address encapsulation and i'd like to know what
rules i ought to follow to cause the least net.strife.  is it the case that
the first character of a domain can't be numeric?  (what about 3com.com?)
is it that the first token must not be purely numeric?  is it the case that
all tokens must not be purely numeric?

speculations, suggestions, and flames all welcome.
Re: can an @domain be numeric?
#94
Author: Neil Rickert
Date: Fri, 21 Aug 1992 19:13
16 lines
1024 bytes
In article <9208211741.AA28843@cognition.pa.dec.com> vixie@PA.dec.com (Paul A Vixie) writes:
>rfc822 implies "yes".  many IBM/VM/SMTP mailers seem to say "no" in that
>if they see
>
>	From: user@10.977.enet.dec.com
>
>they yell about the "1" following the "@".

You can't go by RFC822 on this.  RFC822 was apparently written to be
completely general, and not specific to Internet domains.

The format of hostnames is defined in RFC952, and is amended in RFC1123.
The RFC1123 amendmendments specifically allow digits, so the address you
give is OK.

By the way, some IBM/VM/SMTP mailers reject 3com.com also.
Re: can an @domain be numeric?
#96
Author: Paul A Vixie
Date: Sat, 22 Aug 1992 07:47
8 lines
956 bytes
thanks, neil and andy.  i'll consider specifying my new encapsulation form
to have leading digits, and point these IBM/VM/SMTP hate-mail messages back
at their postmasters.
--
Paul Vixie, DEC Network Systems Lab	
Palo Alto, California, USA         	"Don't be a rebel, or a conformist;
<vixie@pa.dec.com> decwrl!vixie		they're the same thing, anyway.  Find
<paul@vix.com>     vixie!paul		your own path, and stay on it."  -me
Re: can an @domain be numeric?
#95
Author: Andy Linton
Date: Sat, 22 Aug 1992 07:47
46 lines
2752 bytes
In article <9208211741.AA28843@cognition.pa.dec.com> vixie@PA.dec.com (Paul A Vixie) writes:
>rfc822 implies "yes".  many IBM/VM/SMTP mailers seem to say "no" in that
>if they see
>
>	From: user@10.977.enet.dec.com
>
>they yell about the "1" following the "@".

It seems pretty clear to me that this address is 100%. RFC 1123 has
this to say - the emphasis is not mine, it comes straight from the RFC
text. 

   2.1  Host Names and Numbers

      The syntax of a legal Internet host name was specified in RFC-952
      [DNS:4].  One aspect of host name syntax is hereby changed: the
      restriction on the first character is relaxed to allow either a
      letter or a digit.  Host software MUST support this more liberal
      syntax.

      Host software MUST handle host names of up to 63 characters and
      SHOULD handle host names of up to 255 characters.

      Whenever a user inputs the identity of an Internet host, it SHOULD
      be possible to enter either (1) a host domain name or (2) an IP
      address in dotted-decimal ("#.#.#.#") form.  The host SHOULD check
      the string syntactically for a dotted-decimal number before
      looking it up in the Domain Name System.

      DISCUSSION:
           This last requirement is not intended to specify the complete
           syntactic form for entering a dotted-decimal host number;
           that is considered to be a user-interface issue.  For
           example, a dotted-decimal number must be enclosed within
           "[ ]" brackets for SMTP mail (see Section 5.2.17).  This
           notation could be made universal within a host system,
           simplifying the syntactic checking for a dotted-decimal
           number.

           If a dotted-decimal number can be entered without such
           identifying delimiters, then a full syntactic check must be
           made, because a segment of a host domain name is now allowed
           to begin with a digit and could legally be entirely numeric
           (see Section 6.1.2.4).  However, a valid host name can never
           have the dotted-decimal form #.#.#.#, since at least the
           highest-level component label will be alphabetic.
Thread Navigation

This is a paginated view of messages in the thread with full content displayed inline.

Messages are displayed in chronological order, with the original post highlighted in green.

Use pagination controls to navigate through all messages in large threads.

Back to All Threads